Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
2007 EXT Supercharged
Joined
·
1,497 Posts
Discussion Starter #1
Ive read some of the discussions here, and most of you are talking about 90's deville's, mine is rather similar. I just need to make the system work because my ass is dragging. I have an 86 deville with all the similar parts talked about here. My problem is that the compressor wont turn on anymore. It works, but nothing tells it to turn on, i dont get my green "car is leveling" light anymore either. I am also tearing apart an 85 for parts, so i have everything needed if something needs to be replaced. My compressor works, i put in the spare sensor in the rear, and if i hook up 12v straight to the compressor the car begins to rise. But what tells the car when to level?? is it the car computer? I have extra one of everything, i just need to know what to replace. The old car is completely gutted, but i still cant trace the wires too well. Anyone have a book that shows this? Any help would be appreciated Does the system need to be reset or something if i lost power for a week or so?
 

Attachments

·
Registered
´67 Eldorado, ´96 Eldorado
Joined
·
522 Posts
This ELC (electronic level control) sensor is in rear end and attached to control arm, it tells to your car, when it is too low - if you changed it, then its not adjusted correct. You can test it, when you detach sensors link from control arm and move it up and down (ignition on).
If nothing happen, then it must be broken...
 

·
Registered
2007 EXT Supercharged
Joined
·
1,497 Posts
Discussion Starter #3
not the sensor

ok, i guess i forgot to mention some things here, i know how the system all works, and yes i have the arm disconnected, and can move it all the way up or down, and have done this with both sensors now, and nothing happens, so im wondering what "brain" is connected to that sensor. I would say im pretty mechanically and electrically inclined. I have put a volt meter on the five wires going to the sensor, one is ground, the other four are all 12v. Of cours i tried to jump some of these with a wire, only to fry the fuse, which is the trunk release fuse for some reason. Im guessing it is the "brain". which one? there are computers all over the car?
 

·
Registered
2016 XTS FWD Platinum
Joined
·
1,084 Posts
There is a possibility that both sensors you have are malfunctioning since they are both used parts. It is a common failure since the sensor is constantly moving up and down. The Electronic Level Control system is comprised of the compressor assembly, height control module, relay, the 2 rear shocks and the related air tubing. If you can manually turn the compressor on, then you know the compressor is OK. I would check the ELC relay. That's what ultimately turns the compressor on and also turns on the "CAR IS LEVELING" lamp (you can just swap a like relay in the relay panel to check to see if it is functioning correctly). Otherwise, I would get another height control module. All of the electronic circuitry is contained in that unit. One other thing, there is about a 30 second delay before the compressor will turn on or the system will exhaust itself. With the arm disconnected, when you rotate the lever up or down, you do have to hold it there for at least 30 seconds. That time limit is built-in so when going over bumps and such the system will not come on.

Max
 

·
Registered
2007 EXT Supercharged
Joined
·
1,497 Posts
Discussion Starter #5
Hey thanks maxim, do you or anyone have a location of that relay? I have already looked in a Haynes manual and it says take the car to a dealer, so i must have to check a dealer book. Anyway, i have looked all over on this car that im tearing apart, and i cant trace any relay to the system, it all goes into a conjuction box and from there i have no idea. Your right it could be both sensors. I have a working 91 deville, but it has a different plug on it, square instead of round, i didnt really want to cut wires on the working system though.
 

·
Registered
2016 XTS FWD Platinum
Joined
·
1,084 Posts
Do you have an owner's manual? It should tell you where the relay center is. I think it is under the dash on the passenger side of the vehicle. Let me know if you don't have the owner's manual. I will try and locate it for you.

Max
 

·
Registered
2007 EXT Supercharged
Joined
·
1,497 Posts
Discussion Starter #7
ok, found the relays, only what is it called, no description in the manual.

I have

EFE relay

ALC relay

Delay ACC bus relay

Also have BCM Batt fuse

and ECM Batt fuse

ECM ignition fuse

Any ideas or should i just start replacing them??
 

·
Registered
2007 EXT Supercharged
Joined
·
1,497 Posts
Discussion Starter #9
Well i dont know what the hell happend, but it works now. I was driving the car home and it just started leveling. Hmm, dont really know what i did or didnt do. ha
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Chances are it will be a re-occuring problem...... it probably just re-attached a loose connection... but enjoy now that it works!!!
 
1 - 10 of 10 Posts
Top