Cadillac Owners Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Lost all audio in the car and suspect it's the amp. Internet is all over the place with regards to amp location and can't find a single reference to 2012 model year. Just earlier years. Is it driver side behind lower console panel?
 

·
Registered
2010 SRX Luxury
Joined
·
37 Posts
Did you find the amp yet? Like you, I think it is on the driver side to the right of the gas pedal behind the plastic console panel.
 

·
Registered
10 SRX
Joined
·
407 Posts
Just like you (what a surprise) I too seem to be having problems with the amp to my radio/all audio. After some research I believe it is to the right of the gas pedal like Bones said. Amazon seems to have the best price around $150. for a new one. I'd say maybe 1/2 to 3/4 hr time? I'd be curious if anyone made a better plug-in amp?
 

·
Registered
10 SRX
Joined
·
407 Posts
Here is a video for a amp location
Amplifier
This is a really good video by a guy, I think he said his name was Mike. Question I have is has anyone tried disconnecting the wire clips and cleaning them with some good contact cleaner? This could be just a bad connection right? Also Mike said he got his new on at a salvage yard for $130 and Amazon has "brand new" ones for $155. With the number of problems people are having, I'd suggest purchasing the new one for $25 more. (If the problem isn't the connection)
 

·
Registered
'99 eldo blk on blk, '13 ATS,'13 SRX premium
Joined
·
226 Posts
Here is a video for a amp location
Amplifier

I would strongly advise complete disconnection of the battery before any work is done on this part.
This is a really good video by a guy, I think he said his name was Mike. Question I have is has anyone tried disconnecting the wire clips and cleaning them with some good contact cleaner? This could be just a bad connection right? Also Mike said he got his new on at a salvage yard for $130 and Amazon has "brand new" ones for $155. With the number of problems people are having, I'd suggest purchasing the new one for $25 more. (If the problem isn't the connection)
Lost all audio in the car and suspect it's the amp. Internet is all over the place with regards to amp location and can't find a single reference to 2012 model year. Just earlier years. Is it driver side behind lower console panel?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top