Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
CTS-V
Joined
·
59 Posts
Discussion Starter #1
It seems that I need to add a quart a month or so of Dex coolant... Wondering if thats normal, or I may have a problem. There is never a leak spot in the driveway!
 

·
Registered
CTS-V
Joined
·
874 Posts
You've got a problem! 50k miles on my '04 and haven't added a drop.
 

·
Registered
2011 CTS-V
Joined
·
151 Posts
It seems that I need to add a quart a month or so of Dex coolant... Wondering if thats normal, or I may have a problem. There is never a leak spot in the driveway!
Welcome to the "new radiator club". Mine (and numerous other cars on the forum) did the exact same thing and they had to replace the radiator.
 

·
Registered
2005 Cadillac CTS-V
Joined
·
130 Posts
My radiator had to be replaced early on. It had a leak above the water line, so only steam would escape (so water spots).

The irony is, just yesterday, I started smelling escaping coolant again...
 

·
Registered
'05 CTS-V, '00 SLS, 98 SLS, 89 Eldo, '80 Eldo
Joined
·
4,001 Posts
Bringing my 05 in Thursday, for the radiator and a few other things.
I'll see how good my dealer is
 

·
Registered
CTS-V
Joined
·
59 Posts
Discussion Starter #10
I havent had mine serviced yet, since I bought my V used. Just wondering about the issues... It's a 2005 and seems to have small "stupid" grocery list of items.
 

·
Registered
Joined
·
50 Posts
Yep, I got the same problem. I'm glad you posted this thread because I was really wondering about that. I have to add coolant every month as well and have not seen a leak or smelled a thing. I thought it was just the summer heat paying a toll on the cooling system, but now my V will be at the dealer in the morning! Seems like my V is in the shop every damn month too :gah:.

I LOVE THIS CAR.
 

·
Registered
2005 Cadillac CTS-V
Joined
·
162 Posts
I havent had mine serviced yet, since I bought my V used. Just wondering about the issues... It's a 2005 and seems to have small "stupid" grocery list of items.

I bought my 05 used as well. I took mine in today for a rear diff and was telling the guy about the antifreeze smell. He told me right away it was the radiator. He's going to look at it while he's got it but he says at some point I will neeed another radiator.
 

·
Registered
Cadillac CTS-V
Joined
·
235 Posts
I bought an '04 with 14k miles on it.. I have dealt with coolant issues a couple times. 1st time I took it in they told me it had a leaky seal in the water pump which was replaced. 2nd time which was last month.. I had a leaking radiator which was also replaced. All under warranty. So it's all good. In the past 9 months those have been my only problems.
 
1 - 15 of 15 Posts
Top