Cadillac Owners Forum banner
1 - 13 of 13 Posts

·
2016 ATS Premium 6-spd MT
Joined
·
14,391 Posts
Discussion Starter · #1 ·
I debated whether to post this, but .. well ... here goes. After I installed my Volant CAI, the last step was to install the cover on the box (complete with my V emblem instead of the Volant emblem :yup: ). Well, the cover doesn't seal! Toward the front, it appears to be warped, and with only four fasteners to tie it down at the corners, there's a gap of about 1/4" or so between the cover and the mating surface of the box. I certainly don't recall that being the case when first removed it from the shipping box. I'm wondering if the two screws holding it to the radiator support, after being tightened, flexed the box a bit causing this. (They were one b!tch to get in!!) I ended up using weather stripping (yes, EVERYBODY has some of that laying around at this time of year here in Mich) to seal all around the the mating surface of the cover to the box. Seems to be okay, but I'm a bit chagrined to admit this was my "fix". Anybody else notice this problem?:annoyed:
 

·
Registered
Joined
·
1,639 Posts
Im about to purchase one....any more info on this.

ALSO rand49er you notice any performance and hows the sound? Thanks....

I suggest u contact Volant...complain...if you do it nicely, mb theyll send you a new cover.
 

·
Registered
Joined
·
131 Posts
Yup and I plan to fix it with some thin and sorta high-tech looking black weather strip. I don't think the front bolts warped the box, I just think the cover has a natural bow. I was also going to seal it to the fender intake when I got around to it.
 

·
Registered
CTS-V
Joined
·
797 Posts
No warped cover here. Doubt the box install could have caused it to warp, it's pretty sturdy. Is the lid now bowed? Check it on a flat surface. Maybe you can press it flat with a little strategically applied heat and weight?
 

·
2016 ATS Premium 6-spd MT
Joined
·
14,391 Posts
Discussion Starter · #7 ·
04CTSVFLA said:
Im about to purchase one....any more info on this.

ALSO rand49er you notice any performance and hows the sound? Thanks....

I suggest u contact Volant...complain...if you do it nicely, mb theyll send you a new cover.
It's not earth-shattering, but there seems to be a slight performance increase and some slight additional sound level/engine inhaling.
 

·
2016 ATS Premium 6-spd MT
Joined
·
14,391 Posts
Discussion Starter · #9 ·
calicadi said:
No warped cover here. Doubt the box install could have caused it to warp, it's pretty sturdy. Is the lid now bowed? Check it on a flat surface. Maybe you can press it flat with a little strategically applied heat and weight?
You know, I didn't think of the lid being the problem, plus it's a whole lot easier to remove and check than the box ... I think I'll do that. Then, rather than contact Volant again (the technical support never did return my phone call when I called before ... great "support" that is :cookoo: ), I might just make that Home Depot trip.:highfive:
 

·
Registered
2018 XT5 Black on Black
Joined
·
1,847 Posts
I think your on to something ACE. Put a clear fiberglass piece or maybe Lexan and then you would have a view of the blue filter. It would addd a nice bit of color to the engine compartment. My Volant should be here monday or tuesday. I'll look into it and keep you posted. I like it!!!!!
 

·
2016 ATS Premium 6-spd MT
Joined
·
14,391 Posts
Discussion Starter · #11 ·
B Hoth said:
My Volant should be here monday or tuesday.
Say, BTW, check out calicadi's thread on the instructions as they may come in handy. Volant's "instructions" are woefully lacking.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top