Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
Just wondering if this is normal. I know some is normal but I get an excessive amount. Others around me think I'm over heating sometimes if I come to a stop shortly after a wash. It does go away after a few miles of driving though.

I was also wondering if anybody else gets weird outside temp readings on the mirror when sitting at an idle for a long period of time. Mine got up to 117 degrees while waiting in line to get in to the car wash today. Mine will also get a flashing ICE on it sometimes when I 1st start it.
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,854 Posts
There should be no steam coming from the radiator, chances are there is a leak somewhere as far as the temp reading high while sitting at idle thats because its picking up heat from the engine, when you start moving the fresh air passing the sensor will give you a more accurate reading
 

·
Registered
2014 S550, 2018 XT5 Platinum, 2019 XT4 Sport :)
Joined
·
1,742 Posts
It is TOTALLY NORMAL for steam / water vapor from the front of the vehicle after a car wash. I don't think blaze was stating it was anti freeze or a radiator leak, just steam / water vapor.
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,854 Posts
My bad i didn't notice after a wash... Yeah you're totally ok
 

·
Registered
Joined
·
137 Posts
Discussion Starter #5
Yes just a lot of water vapor coming from the radiator. There is no coolant leak at all just a massive amount of steam from the car wash. I've never had a vehicle do this so bad before. I'm use to seeing a small amount of steam after a wash but this thing does it really bad until I've drove it a few miles. I guess the cooling fins on the radiator just hold a lot of water from the wash and it takes a little bit to dry it out.

As far as the temp sensor goes I figured it would pick up some heat from the engine bay but didn't think it would that much. I still don't get the ICE flashing message on the temp reading. Maybe it's trying to warn of possible ice on the road or something.

----------

Guess I should say I don't understand the ICE thing instead of not getting it.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
It's normal due to the heat build up under the hood mine does it a lot in a car wash
The temp sensor should give the ice warning if it gets 32 or below I have seen it many times lately due to the extreme cold we have had here this past two week
 
1 - 6 of 6 Posts
Top