Cadillac Owners Forum banner
1 - 5 of 5 Posts

Registered
2013 ATS 2.0 6-sp Premium
Joined
460 Posts
I'm sure some people will be around tomorrow to offer some advice, but that picture alone doesn't tell us that much. Were there any other warning lights or messages? Is the car driving normally? Did someone accidentally (or without your knowledge) simply press the buttons that deactivate TC and stabilitrak?
 

Registered
Joined
4 Posts
Discussion Starter · #3 ·
The engine almost died. It acted like it sputtered when I parked and then this display appeared. I restarted the car and it still had these warnings so I drove it home and turned it off and on several times. Took it down the street and it acted like it wasn't shifting correctly, in automatic, I never use manual. It then acted like it was okay after I stopped and got on the engine but the engine light remained on.
Almost acting like it's not getting power properly. Haven't drivin it since however but this has never happened and I've put Almost 3k miles since purchase. I appreciate your comment and help a ton!!
 

Super Moderator
2019 XTS Luxury AWD, 2004 SRX N* AWD (gone)
Joined
3,651 Posts
There are a number of issues that could cause this. You have warranty - I suggest you contact the Dealer to have them check for codes and test drive. It might be something as simple as needing new transmission fluid. Best of luck!
 

Registered
2014 ATS 3.6 Premium RWD, 2016 Corvette Z06, 2018 GMC Sierra Denali 2500HD Diesel
Joined
3,506 Posts
Get it to the dealer and they will retrieve the trouble code(s) that are stored after the engine event. The service stabilitrak doesn't mean much because any time there is even a minor engine malfunction, the traction control and stability systems are disabled because they cannot operate properly unless the engine is running exactly as intended. The transmission also cannot shift properly with an engine not providing the requested power output so the transmission behavior (very late shifts allowing the engine to run at higher RPM I suspect) happened because the engine wasn't able to reduce its normal power at lower RPM.

Rodger
 
  • Like
Reactions: robertorolfo
1 - 5 of 5 Posts
Top