Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Allante 1989 export running on LPG
Joined
·
57 Posts
Discussion Starter #1
I have recently moved the front seats from a 1999 STS to my 1998 SLS, The Donor car had memory seats and my car does not.
So now every time I get in the car the seat moves back into the last position set when it was in the donor car. :)
I have tried to get used to the position as it's not miles off but I normally end up adjusting it.
I am not bothered about having the seat memory function so i was wondering if there is a wire I could snip or another solution which would still allow me to move the seats but stop them moving themselves.
I do still have the original seat if needed but they are not so nice and cause an intermittent airbag light so re-fitting them is not desirable
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,481 Posts
Does the 1998 have the personalization buttons on the driver's door panel ?

If it does, and you start the car and press MEM 1 or SET 1 and then adjust the seat, then press SET again, does it work ?
 

·
Registered
Allante 1989 export running on LPG
Joined
·
57 Posts
Discussion Starter #3
No, It doesn't have those buttons
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
The memory seat module is on the underside of the seat, but I have no idea what would have to be done to disable it.
 

·
Registered
Allante 1989 export running on LPG
Joined
·
57 Posts
Discussion Starter #5
I did try disconnecting the memory module but then I had no power seats. I think the answer is in my old seat base, I may have to move some parts over.
 

·
Registered
Allante 1989 export running on LPG
Joined
·
57 Posts
Discussion Starter #6
Re: Amusing power seat problem SOLVED

I have solved the problem by cutting the purple data link cable at the seat harness, Now I can move the seats but they don't move back when I get in and out of the car.
I have a question if any expert on the data link can help me.
I have also moved the door from the donor car (Which had memory function) and I can see the purple data link wire is going from the door control module, out through the door harness. But the buttons on the door don't do anything.
I have looked at the wiring diagrams and I can't see any other component needed to make the memory function work.
 
1 - 6 of 6 Posts
Top