Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
1995 Eldorado
Joined
·
32 Posts
Discussion Starter #1
Yo guys well once again i think my alternator is going. Was driving the other night and all of a sudden my "battery no charge" message came on. Thought nothing of it at first figured dead battery. Was driving home and lights started to flicker and "battery volts low" message pops on. Made it home then next day it wouldn't start. Drove it to a local garage and got my battery replaced under warranty. Thought that would fix everything but the "battery no charge" message was still on. P-d me off. It starts and everything but the battery reads around 11.4 to 11.6 volts and thats when driving and just started. Now i checked the codes and p110 pops up and thats the generator l circuit problem. Looked around and saw that it was alternator for other people. Assume im going to get the same answer but figured i'd test it out anyways. Going to autozone tomorrow to have them test it. Thats if i make it
 

·
Registered
90 Eldo -SOLD-, 98 ETC -SOLD-, 86 XR4Ti Track Car, 07 Ranger
Joined
·
963 Posts
yeah, way low, alternator almost guaranteed, should be putting out 13-16V at 2000RPM depending, most peoples run in the 14s...
 

·
Super Moderator
2010 DTS
Joined
·
87,547 Posts
Do yourself a favor and don't buy it from AutoZone. Either have yours rebuilt at a shop that rebuilds starters and alternators or buy an A/C Delco unit.
 

·
Registered
1995 Eldorado
Joined
·
32 Posts
Discussion Starter #4
ya i have bought it from a local shop the first two times it went. Im hoping its under warranty still because after they put the first one in about a week later it went again and i got it replaced for free so im hoping my warranty will help me out here. Not sure what kind of alternator it is but tomorrow i should know what is going on with it
 
1 - 5 of 5 Posts
Top