Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
Joined
·
1,150 Posts
Discussion Starter #1
Hi, I own a 1980 Cadillac Coupe and recently the dash light has been coming on. When I would start the car there would be a screeching sound and my guess it was a belt and turns out it was(alternator belt) So I adjusted it and still have the light on. So took it to have it looked at while in car and said it's not putting out correct amount. So I removed it took it in and it passed 2 out of 3 times tested, took it to another parts store and it passed 2 of 2 times tested; guy said to replace belt, so I did but today when driving it's still on. Not brightly lit but just faintly you can see it and when at idle(whether parked or light) it glows more and when I accelerate it dims out. What can it be? They won't replace it because is passes; battery cables look OK(never replaced in 10yrs.) battery is a fairly new(can't recall when bought)have receipt. So what else do I need to look at?
Thanks guys, love this forum.
 

·
Registered
83 Eldorado, 90 Seville, 94 Concours
Joined
·
469 Posts
You didnt mention if your battery is going dead. Also are you dealing with a warrenteed alternator? If so, is it a remanufactured unit. It could be a faulty regulator, or just poor ground connections. Give your battery terminals a good cleaning and inspect your cables closely for any sign of crossion. You might have to slice the cable jacket back from the end a little to see if any crossion exists along its length. If so the cables should be replaced. Check the engine data information display for charging output. Should be 14 amps.
 

·
Registered
78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
Joined
·
1,150 Posts
Discussion Starter #3
You didnt mention if your battery is going dead. Also are you dealing with a warrenteed alternator? If so, is it a remanufactured unit. It could be a faulty regulator, or just poor ground connections. Give your battery terminals a good cleaning and inspect your cables closely for any sign of crossion. You might have to slice the cable jacket back from the end a little to see if any crossion exists along its length. If so the cables should be replaced. Check the engine data information display for charging output. Should be 14 amps.
The battery is fine; don't have any starting problems whatsoever. The alternator is one of those remanufactured ones; I took it in to Autozone and I gave them like 5 phone numbers as I can not recall which number I used for the warranty anyways turns out it's not from there; that's where it failed once and passed twice. So took in to Pep Boys and the lady immediately said it's not theres because it does not have "markings" on it that would identify it's from that store, so I had it checked out with them and it passed twice. But today I went through my all my receipts and I found it! It is from Pep Boys (stupid lady) So took it today and explained to them what happen on Saturday. But like I said everything is fine nothing loose, no corrossion, but I'm taking it in on Wednesday to have the battery looked at and I'll go from there. BTW, my car does not have "the engine data information display" that you mention above; it's a 1980 Cadillac Coupe. Much thanks!:)
 

·
Registered
83 Eldorado, 90 Seville, 94 Concours
Joined
·
469 Posts
I went through 3 remanufactured alt's I had purched from Napa, each one lasting about a month before they gave me a new one for my 90 Seville. That one also is making a high squeel. Im so glad it was easy to R&R. Where can we get decent parts?:rant2:
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,738 Posts
A dim gen light is usually a failed diode within the alternator. It will pass charge output tests. A failed diode allows a back feed of electricity which powers on the dash light dimmly. Bottom line, its a faulty reman alternator. If not replaced, it will eventully shorten the battery's life. Best luck over the years with me has been only to use DELCO brand rebuilt starters and alternators.
 

·
Registered
1993 Cadillac deville sedan 1986 cadillac deville RIP
Joined
·
1,498 Posts
That's true I had a bad diode in mine and I had the same problem usually when starting it up go get the alt rebuilt.
 

·
Registered
78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
Joined
·
1,150 Posts
Discussion Starter #8
hey guys I'm back. So here's the scoop. Went on Wednesday (7-8-09) to Autozone and they told me that my battery is bad and that is what is causing the light to come on, I was like that's not right, how can the battery cause this, and she said it happens and again it was a girl who told me this. Anyways, so I went ahead and replaced the battery later that day; light still came on, so on Thursday I was fed up and went back to Pep Boys and told them, look I have already replaced the belt, battery, cables, and car is at an electrician repair shop getting looked at, it HAS to be the alternator. They didn't even bother to check and was giving a replacement, but when removing the old alternator, the plug that connects to alternator one of the wires snapped off right where it connects to the plug, I was like :banghead: so I managed to fix it and installed the new one and today was driving it and no more light comes on.
I think these auto parts stores should not hire girls; they don't know.
Just my $0.02:)
 

·
Registered
83 Eldorado, 90 Seville, 94 Concours
Joined
·
469 Posts
The rebuilders must using the cheapest bearings, brushes and diode's available. I wonder what the warranty replacement numbers are?
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,738 Posts
A rebuilt is usually swapping of core parts to make a rebuilt. So diodes and bearings can be suspect.
 

·
Registered
1993 Cadillac deville sedan 1986 cadillac deville RIP
Joined
·
1,498 Posts
So what's the update if you. Hear a sweaking noise have your tenisoner looked at make sure ur battery is fully charged when you drop your new alt. In
 

·
Registered
78 CDV, 79 CDV delegance, 80 CDV, 80 FWB 2dr delegance (rip)
Joined
·
1,150 Posts
Discussion Starter #12
So what's the update if you. Hear a sweaking noise have your tenisoner looked at make sure ur battery is fully charged when you drop your new alt. In
UPDATE is that I have already taken care of the problem. It was the alternator the whole time but was giving the run around at the auto parts store that it is the battery. So , I got a new battery, I exchanged my alternator for another and bought new terminal bolts for my battery.
It does not have a tensioner at you mentioned; it is not a serpentine type belt. Mine has 3 belts. Thanks
 
1 - 12 of 12 Posts
Top