Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
None
Joined
·
29 Posts
Discussion Starter #1
I have a 97 Deville, alternator is charging properly but lights are flickering at idle and also as I increase the RPMs. Thinking it could be internal regulator? Any way to test this? What's the correct procedure to remove the alternator, looks like it might come out from the bottom. Thank you.
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
Re: Alternator

might just be increased resistance from corrosion--clean the battery terminals, grounds, power wire from the alt, etc, see what it does
 

·
Registered
Alexandra - 96 SDV Clyde - 15 Silvy
Joined
·
6,394 Posts
:yeah:

IF you do what ehall recommended, and the problem persists, I would take the car to a parts store. They test that stuff for free.

In my highly uneducated, total amateur mechanic opinion, I would bet that the regulator may be starting to go. What are volts with the engine running? How bout with the key in the on position and the engine off?
 

·
Registered
1994 deville
Joined
·
51 Posts
hi my 94 roadmaster was doing the same thing . took twice to auto store there machines said good ..but being in the ac trade had really good meters etc I saw that my voltage was not staying at a steady level. but going from 12.8 to 14.9 after cleaning the grounds etc. the lights still slightly flickered or pulsed ..and also with my tuner pro seeing the comp data it was showing that the knock sensors were sensing knocks when there wasn't any how ...rock auto owed me credit for a bad optisark dist .so I got a new gm alt showed up and put on ..flicker is gone away and car did run great the computer even showed that the knocks were gone too .. so it could be that one of the pole windings is going bad in the alt sending what I call dirty voltage to car .. is your voltage swaying or staying steady?
 
1 - 4 of 4 Posts
Top