Cadillac Owners Forum banner

1 - 17 of 17 Posts

·
Registered
Cadillac
Joined
·
7 Posts
Discussion Starter #1
I have a 99 deville, I had the AC system replaced, I only drove the car maybe 5 miles and the same thing happend, the AC cuts off, low refrig code and goes to economy mode. I took it back to the shop and they replaced low pressure switch, I drove it 30 miles, the same thing happened then they thought they had it fixed and I drove it another few miles and the same thing happened. Does anyone know what is wrong?
Thanks for your help
Dntexas
 

·
Registered
97 Deville
Joined
·
93 Posts
Well my first guess would have been the low pressure sensor my second guess would be to check the refrigerant level since you said that you just got your a/c replace because i was getting the same message and i thought i was going to have to replace the entire a/c system which i think is a common scam fix for some mechanics because they wanted me to pay $1000 to have the system replace anyways i took it to a local shop and they check the refrigerant and said that there seemed to be enough in the system but my compressor would not kick on so they charged the system a bit more and my a/c started working again but and since they put some a/c dye in the system i found my leak which is very small located on one of my sensors in my a/c line. So i would have them check the pressure and get a second opinion from another shop if you can.
 

·
Registered
Cadillac Deville 1990
Joined
·
266 Posts
dntexas where you located at? I agree with pnj2108 have another tech look at it does not seem like the fools you are going to know what they are doing.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,997 Posts
You might find the answer on the other side of the steering wheel. Pull the codes.
 

·
Registered
Cadillac
Joined
·
7 Posts
Discussion Starter #6
Ok guys,:confused:
Thank you all for your input..However, 1st you are dealing with a lady here.So I told the shop working on my car all of your suggestions, so far they have done that,pulled the codes and have had 3 cadillac techs look at it and now they are saying a programmer may be the problem. The orifice has been replaced 3 times the sensors 2 times , the air shuts off and the pressure is good. They have told me if the programmer doesn't work I don't have to pay for it, quite expensive I understand. Thank you so much for all your suggestions. Does this happen often in Cadillacs? This is the first time I have ever encountered a problem like this.
D
 

·
Registered
1997 Deville
Joined
·
47 Posts
I'd be interested in this...

Drive car with AC on, wait for the code, keep driving to get where you need to go.

Clear the code (we can teach you how to do that).

Once the car has sat a sufficient amount of time (an hour or so) AND the code has been cleared, see if the AC works fine for a little bit again.

My thinking...The system may not be charged correctly and the evaporator core could be dropping below freezing...which means the moisture (that you usually see dripping under a car when you have been parked with ther AC on) could be turning into ice causing a few problems that might be difficult for a tech to spot once the ice has melted.

The other check I would do when the AC is working correctly for the time being is to pop the hood and go to the passenger side of the engine compartment. You should hear a clicking sound once every x seconds (some else fill in the x here, I need a new compressor so I can't tell the cycle on/off time). If the AC is running continuously (you hear no clicking) there is another problem.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,997 Posts
X will be variable depending on ambient temperature. The hotter it is, the shorter the cycle. It may even run continuous in very hot temperatures like high 90's or over 100 I think.
 

·
Registered
Cadillac
Joined
·
7 Posts
Discussion Starter #10
Thanks for your comments thus far but the problem still exists. I'm not sure if they have noticed or not as to whether the evaporator is freezing up but since they have replaced the other things so often wouldn't they have noticed that? Also, now they tell me that the air conditioner doesn't even come on at all. They are going to try to replace a programmer (?) and see if that solves the problem. What is a programmer? Is it a computer chip or something? They mentioned that the programmer must be in the $700.00 range. The dealer will take it back if that is not the problem. Any further ideas? Thanks a lot!
 

·
Registered
1997 Deville
Joined
·
47 Posts
I hope that they have been deleting the low refrigerant code from the computer history...otherwise that might be the only thing wrong. Even with the correct amt of R-134A, if the code exists, the AC will not work.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,997 Posts
The "programmer" aka Air Conditioning Module (ACM) is the HVAC brain and it IS expensive. Being electrical I am surprised that the dealer will take it back.
 

·
Registered
Joined
·
7 Posts
ranger i need help . its about 100 degrees out and no a/c . i had my p/s pump changed last year by a friend and he had to dissconnect the comp and let the freon out . ok , then i didnt use the a/c all winter now i tried to use it and its warm . i tried charging it ( the proper way) but it won't take the recharge. now , when i get in the car after it sits overnight it comes out cold for about 1 to 2 minutes then gets warm again please help me as youve saved me before . much appreciated thanks Anthony ps its a 96 deville with 160k
 

·
Registered
Cadillac Deville 1990
Joined
·
266 Posts
Has anyone thought about a leak here? I know she took it in but that does not mean there is no leak otherwise how is the freon escaping?

dnTexas you did say you lost pressure right? When you took it back to the shop did they say that you needed to be recharge or anything? Hmmm the shop should fix this if they replaced the system.

By the way I live in Houston to so I might be able to look at your car and see what I can find out if you like?
 

·
Registered
Cadillac
Joined
·
7 Posts
Discussion Starter #15
:thumbsup:Just wanted to let you guys know that the ACM module as Ranger stated was EXPENSIVE and it is working great now. I drove the car so far about 40 miles and still have air. Thank you guys so much for all of your help
Nice to know I have someone in Houston I can call on. I sure do appreciate the offer of assistance and hopefully this is done with.

Next when I get some money I may need to look at replacing those headlight lenses. They are getting mighty dull looking any ideas ?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,997 Posts
Headlight "lenses" are not replaceable. You have to replace the entire headlight assembly. That is expensive, but you can polish them up to like new condition with some 1000, 1500 & 2000 grit wet sand paper then finish them off with Meguiars #10 & #17.
 
1 - 17 of 17 Posts
Top