Cadillac Owners Forum banner

1 - 18 of 18 Posts

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #1
Its Roblee, it's been over a year since I tore my pretty blue onyx SLS up, finally back in another Cadillac. A 2004 Deville base model, picked the car up for only $200 bucks with clean title. It has issues, sometimes it doesn't wanna come out of park, the gear lever would still move but the car would remain in park, motor has a mild knock to it but it runs good. For what I paid for it, its definitely worthy of a fixer upper project. Oh and i can't remember my login for my main account which was Roblee22 I believe, I would like for a moderater to merge this account into my old one I was using last year.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,658 Posts
Its Roblee, it's been over a year since I tore my pretty blue onyx SLS up, finally back in another Cadillac. A 2004 Deville base model, picked the car up for only $200 bucks with clean title. It has issues, sometimes it doesn't wanna come out of park, the gear lever would still move but the car would remain in park, motor has a mild knock to it but it runs good. For what I paid for it, its definitely worthy of a fixer upper project. Oh and i can't remember my login for my main account which was Roblee22 I believe, I would like for a moderater to merge this account into my old one I was using last year.
===================
welcome back -
Sub and I were just talking about your '99 SLS with the FE1/F45 suspension -

STEP #1 - ALWAYS - check for DTC's - Diagnostic Trouble Codes - using the on-board scanner -
if you don't remember how - go here -

post any codes you have -
ALONG WITH THEIR DEFINITIONS -

include whether they are C-Current or H-History -

for code definitions - go here -


here is a how-to video -
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #4
===================
welcome back -
Sub and I were just talking about your '99 SLS with the FE1/F45 suspension -

STEP #1 - ALWAYS - check for DTC's - Diagnostic Trouble Codes - using the on-board scanner -
if you don't remember how - go here -

post any codes you have -
ALONG WITH THEIR DEFINITIONS -

include whether they are C-Current or H-History -

for code definitions - go here -


here is a how-to video -
Haha I miss that SLS so much, I think about it everyday(along with all the foolish things I did when I owned it). I got a fresh start with everything now, I'm gonna treat this deville like the fine mobile it is. I ran the codes and there's none, it runs good, but it has a knock to it. I ordered another 2004 vin y motor with only 90k miles for $600, should have it installed in a few weeks or so, in the meantime, I'm gonna fix the little dings and dents that's on the body. And oh yeah, you all know I'm gonna make it a DTS clone with the painted ground effects, fogs and stuff, but I'm doing it right this time. Glad to be back

Sent from my SM-A205U using Tapatalk
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #5
And hopefully I wont have any overheating issues from a 2004 motor. But one thing I dislike about the car so far, previous owner put the 16 inch STS wheels on it, they just look wrong on a Deville imo...

Sent from my SM-A205U using Tapatalk
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,658 Posts
Haha I miss that SLS so much, I think about it everyday(along with all the foolish things I did when I owned it). I got a fresh start with everything now, I'm gonna treat this deville like the fine mobile it is. I ran the codes and there's none, it runs good, but it has a knock to it. I ordered another 2004 vin y motor with only 90k miles for $600, should have it installed in a few weeks or so, in the meantime, I'm gonna fix the little dings and dents that's on the body. And oh yeah, you all know I'm gonna make it a DTS clone with the painted ground effects, fogs and stuff, but I'm doing it right this time. Glad to be back

Sent from my SM-A205U using Tapatalk
=========================
you all know I'm gonna make it a DTS clone with the painted ground effects, fogs and stuff
the fogs are a LOT of work and expense for the return -
bumper cover - fog lights and mounts - wiring harness - headlight switch - etc -

the analog cluster is a MUST - and not to difficult to do -

removing the front/center seat and replacing it with a console requires a little "rigging"
there are a couple of HowTos in the TechTips forum - Ranger did that to his DHS -
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,658 Posts
And hopefully I wont have any overheating issues from a 2004 motor. But one thing I dislike about the car so far, previous owner put the 16 inch STS wheels on it, they just look wrong on a Deville imo...

Sent from my SM-A205U using Tapatalk
===================
I agree -
I think the nicest looking wheels on a Deville are the 14 spoke wheels from a DHS -
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #8
I might end of switching the wheels with some from a DTS performance, them 18 inch wheels look perfect. This car have the turn signal indicator on the mirror which I like, it also has cooled seats and memory seats which I did not expect a base model to have, all in all. I normally always preferred Sevilles, but I feel like this generation Deville looks more up to date than the Seville(led tail lights found on newer Cadillac models, the side profile of the car resembling newer models).

Sent from my SM-A205U using Tapatalk
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #9
Its having a no crank issue now, when I turn the key to the start position, I can hear the relays under the rear seat click, but no started engagement. It seems like the car acknowledges key movement, so I would guess the ignition switch is still good. There are still no check engine codes, I just put a brand new battery in it, group 79, what should I look for? Starter maybe?

Sent from my SM-A205U using Tapatalk
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #10
One thing I now noticed, when I scan the codes, it now says no pcm data, so that tells me there's some miscommunication between the pcm and the car, could that mean a bad pcm stopping the car from starting? The interior and dash does all kind of crazy things sometimes.

Sent from my SM-A205U using Tapatalk
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #11
Also last night when I tried to start it with the old battery, I heard the starter solenoid click under the hood but no start. I had the battery load tested at auto zone as soon as I bought the car and it fail terribly so I got a brand new one. Non running volts on the new battery was 12.6 right off the shelf, so I dont think the battery is the issue. Also, it doesn't miscommunicate with the pcm all the time, last time I scanned the codes, the pcm codes came back as no pcm codes. I'm ok with putting money into it, car only has 134k miles. I'm gonna do some more test tomorrow, just needed to be pointed in the right direction.

Sent from my SM-A205U using Tapatalk
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,658 Posts
start with checking grounds
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #13
Checking that ground the runs from under the fuel panel to the starter I believe was one of the first things I looked at, it was connected and tight, but it was covered with oil, would that cause this issue? I also checked the grounds under the rear seat and everything was intact.

Sent from my SM-A205U using Tapatalk
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #14
I made a typo in my last post, the ground I checked actually went from right under the fuse box to the started I believe and it was good. I went back to the car earlier this evening, put the battery back in, radio, dice information and climate control worked, but the window buttons did not, I tried to start her, and I hear the relay click and I also heard the starter click but no start. I no longer have the patience to diagnose/fix cars like I once did, so I decided the car is going to Joe at Midwest Cadillac sometime towards the middle of the upcoming week, I'm gonna have them fix EVERYTHING on my new to me black Deville 2004, I'll be sure to update on the progress. I've been part of several different auto maker forums and this is by far the very best!

Sent from my SM-A205U using Tapatalk
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,658 Posts
I made a typo in my last post, the ground I checked actually went from right under the fuse box to the started I believe and it was good. I went back to the car earlier this evening, put the battery back in, radio, dice information and climate control worked, but the window buttons did not, I tried to start her, and I hear the relay click and I also heard the starter click but no start. I no longer have the patience to diagnose/fix cars like I once did, so I decided the car is going to Joe at Midwest Cadillac sometime towards the middle of the upcoming week, I'm gonna have them fix EVERYTHING on my new to me black Deville 2004, I'll be sure to update on the progress. I've been part of several different auto maker forums and this is by far the very best!

Sent from my SM-A205U using Tapatalk
======================
I decided the car is going to Joe at Midwest Cadillac
good choice -
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #16
======================
I decided the car is going to Joe at Midwest Cadillac
good choice -
I found this connector disconnected, wonder what it goes too, it comes out a loom that goes to the fuse box.

Sent from my SM-A205U using Tapatalk
 

·
Registered
'98 Seville STS
Joined
·
15 Posts
Discussion Starter #17
I found this connector disconnected, wonder what it goes too, it comes out a loom that goes to the fuse box.

Sent from my SM-A205U using Tapatalk
I wonder if it plays a role in my issues, cant find where it connects to tho.
20200624_152511.jpg
20200624_153220.jpg


Sent from my SM-A205U using Tapatalk
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,658 Posts
that's a mighty short pigtail -
IF that plug was used - and it might NOT - the other end isn't far away -

what (electrically) doesn't work properly?

one thing that comes to mind is the coolant level sensor -
do you get the CHECK COOLANT LEVEL message?
 
1 - 18 of 18 Posts
Top