Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2015i Escalade Premium
Joined
·
408 Posts
Discussion Starter #1
There were two issues within days after I took delivery........the front power outlet did not work, the OnStar system and integrated navigation died......both were fixed 500 miles ago and are working as expected. Everything else has been great! Fit and finish are still very good.....have seen no signs of "sloppy work" ......performance is as good or better than the Benz GL that I traded! The Cue system.....well, it's wonderful!! .....when you compare it to the convoluted and dated system that MB is using!
The LED headlights are phenomenal , the 4WD system worked flawlessly through all of the recent snow mess here in the Northeast! I am very satisfied with this vehicle and the service of my Caddy dealer!
 

·
Registered
Joined
·
5,309 Posts
I am at 6,500 miles and I have a long list of things that need to be addressed. Good old GM build quality and engineering. If the Escalade styling wasn't so nice and wasn't so different from every other automaker's design language, I would have left the GM family years ago. Everything was good until about 2,500 miles and then stuff started going downhill real fast! Such a hassle to keep taking the car back in to the dealer.
 

·
Registered
2015i Escalade Premium
Joined
·
408 Posts
Discussion Starter #3
GM-4-LIFE said:
I am at 6,500 miles and I have a long list of things that need to be addressed. Good old GM build quality and engineering. If the Escalade styling wasn't so nice and wasn't so different from every other automaker's design language, I would have left the GM family years ago. Everything was good until about 2,500 miles and then stuff started going downhill real fast! Such a hassle to keep taking the car back in to the dealer.
I'm sorry that you have had that kind of experience.........I will feel the same if that happens to me!!
 

·
Registered
18 LEXUS LX, 17 Rav4, 15 Escalade ESV, 14 Mercedes, had Vette, 2Cadis, T-B & Chevy
Joined
·
1,041 Posts
I am about 500 miles from your threshold.
at 2000 miles and 2 months no real problems.

I am at 6,500 miles and I have a long list of things that need to be addressed. Good old GM build quality and engineering. If the Escalade styling wasn't so nice and wasn't so different from every other automaker's design language, I would have left the GM family years ago. Everything was good until about 2,500 miles and then stuff started going downhill real fast! Such a hassle to keep taking the car back in to the dealer.
 

·
Registered
2009 escalade hybrid
Joined
·
3,744 Posts
Just turned 5000 miles, almost a month of ownership. No problems except for a casting very slow leak from the waterpump manifold which the dealer fixed quickly. Other than that everything's working as advertised.
 

·
Registered
Joined
·
67 Posts
I have about 2,700 on mine and I just got it back from the dealer the other day... Only a few minor issues like.... left mirror would not unfold all the way out when unlocking via keyfob (replaced mirror), slight vibration in front end (balanced front tires), clunking sound when accelerating from a stop (spare tire hoist was loose), seatback on driver's seat was coming off (replaced seatback)
 
1 - 7 of 7 Posts
Top