Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
STS
Joined
·
40 Posts
Discussion Starter #1
I got a 99 with all the problems i have seen here.. this site has helped me SOOOOOOOO much. Everyday my car brings me something new from shop to shop until i found this site that helps me fix it recently replaced my heater control valve in 30 minutes from information on here, saved me from paying the shop 850.00 "AGAIN"... THANKS..The problem now is that when accelerating from 40 or so up, it spits and sputters like its missin. I had it in the shop a few months back and was VIOLATED for about 2,100 after my insurance plan. they replaced the mass airflow senser and plugs but not wires. would bad wires cause it to do this without throwing out a code or lighting up my check engine light? I have also replaced the fuel filter recently to try that. but when I add a fuel injector cleaner with TECRON it runs better but still spits some. injectors?? I would appreciate any ideas someone could offer.....
 

·
Registered
Joined
·
190 Posts
hey dirty my 99 does the same thing. but we do not have plug wires on the 99's the spark plug boot it connected right to the ignition coil. Do you have any codes that are reading out. cause my check engine light only comes on when it sputters but it goes off. but i still have two codes the 135 and 155 see my post on here. also if you figure it out email me it [email protected]
 

·
Registered
Joined
·
199 Posts
Im no expert but my friend had the same problem on his escalade, and it turned out to be the fuel pump, becuz it wasnt providing enough pressure to meet the load requirements of the engine! Just a tip for sumthin to check out !
 

·
Registered
Joined
·
190 Posts
Well I was on another forum (I Know I cheated on this one but hopefully she don't know) and many people said the mass air flow sensor. with it being the weekend I did not feel like going to the dealer to order one so I just disconnected it to see what happens and now it runs almost perfect so I will have to order one come one. does anyone know what the part# is for the 1999 mass air flow sensor, also I just noticed that my heater control valve just starting dumping coolant out so I will have to change that out also. Ben
 

·
Registered
STS
Joined
·
40 Posts
Discussion Starter #6
thanks for the tip on the fuel pump, hopefully its that or some sort of fuel pressure regulator. It seems to run perfect other than at about 65 and up sputters like its starving.is that what your friends did?
 
1 - 6 of 6 Posts
Top