Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac 98 Sedan deVille
Joined
·
4 Posts
Discussion Starter #1
First of all I would like to say hello to all, I am new to the forum. I just purchased a 98 Sedan with the Northstar motor. She has an intermittent gurgling knock that seems to be coming from the top end of the motor. One of my buds SWEARS that he had a similar problem with a GM motor and as soon as he went to a AC filter he no longer had this issue:stirpot: I have read different posts on some issues with the northstar, but none of them were actual rod knocks. The car has 160k on the odometer, and both the oil and antifreeze were fine(no mixture in each, or shavings from a rod). Have any of you guys used Seafoam through your injection system, or in your oil, or heard anything about the AC filter thought?

THANKS IN ADVANCE
 

·
Registered
Sedan de Ville, CTS
Joined
·
4,764 Posts
Air in cooling system, if you are lucky. Bleed cooling system.

Or start praying that motor has not been cooked. (My unfounded supposition.)
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,982 Posts
Check the purge line to be sure it is clear and flows coolant. That is the line that clears the system of any air. Are you overheating?
 

·
Registered
96 Eldorado
Joined
·
2 Posts
I have have a 96 eldorado that has had the head gaskets replaced but now has a pretty bad engine knock sounding like the top end. It started with like a dry knock in the am. But now has gotten consistent with rpms. Is the motor going?
 

·
Registered
96 Eldorado
Joined
·
2 Posts
I guess i should have given more detail.. I purchased the car from a guy who replaced the head gaskets and did a few other things also. When i got the car it had a few problems with injectors, o2 sensors and maf sensor. I have fixed all of that for the most part. The car has no codes and runs pretty good other than poor fuel mileage. I do still get an antifreeze smell right before the cooling fans kick on. But the engine never overheats. There is no mix in the oil or coolant. I have changed the oil and i still have a fairly bad engine knock on acceleration. I put in Rotella 10w 30 because in live in Minnesota. But i would like to try a thicker oil. Any ideas or suggestions. Is it a dead horse?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,982 Posts
Could be a bad knock sensor (rare). Maybe a stuck EGR valve. Have you pulled the codes?
 
1 - 6 of 6 Posts
Top