Cadillac Owners Forum banner
1 - 5 of 5 Posts

· Registered
2019 XTS Prem Lux AWD Phantom Gray/Ebony traded 2017 CT6 Prem Lux AWD Stellar Blk
Joined
·
1,041 Posts
Has anyone had any issues with AC, car is only 2 1/2 yrs old and 22k miles on it, compressor is not turning
I had a 2017 and had issues with the AC not cooling after I had driven for about 45 minutes. At the time the dealership did not think I had the issue of the compressor freezing up which was a known problem that at that time there was no fix for.
A year later I demanded an answer and after the service manger took my car for a day and saw the problem for himself he stated that he felt my AC was experiencing the known issue and that there was now a fix for it. It turned out that I had a bad evaporator core seal that was not seated properly which was causing a leak and causing the compressor to freeze up.
The entire dash had to be removed to make the repair. There is a service bulletin out on this so make certain that service pulls up the bulletin. I had only had my car for about 8 months and 5,000 miles when I experienced the problem with the AC and it was not good. On a couple of occasion it was extremely hot and the AC would fail and I would be driving a 300 mile round trip with no AC.
You are probably getting very little to no air flow from your AC vents and for the most part you are getting warm air. It is a warranty repair so you will not be paying for it.
There is also a Thread on this issue which I have several post about my experience concerning the AC issue.
Good Luck
 

· Registered
2019 Cadillac CT6 PremLux replacing 2017 CT6#2, Replacing CT6#1
Joined
·
229 Posts
When my AC was going through a quirky phase, a tech's note on the service bulletin suggested setting the temp to 'Lo' so the fan runs high (not kidding). That was two CT6's ago and the current one seems fine with the fan speed reacting to the temp setting, so far.
 

· Registered
2019 XTS Prem Lux AWD Phantom Gray/Ebony traded 2017 CT6 Prem Lux AWD Stellar Blk
Joined
·
1,041 Posts
When my AC was going through a quirky phase, a tech's note on the service bulletin suggested setting the temp to 'Lo' so the fan runs high (not kidding). That was two CT6's ago and the current one seems fine with the fan speed reacting to the temp setting, so far.
I can beat that. I had a brand new 2007 Lexus LS460 and the glove box shook like crazy. After three failed glove box replacements Lexus sent out a Customer Service Rep who said, oh, the glove box was designed to shake so it would not squeak. There was also bad wind noise at the driver and passenger window that he was the only one in the car who could not hear it. I traded out of the car and walked away from Lexus never to return.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top