Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Cadillac
Joined
·
4 Posts
Discussion Starter #1
On June 25, 2007, I posted this:

Hello. I'm new to this forum and need some help.

About a month ago, as the weather got hot, I noticed that my '95 DeVille's auto climate control would not run the blower on high when the car had been sitting in the sun for the day. I could set the temp. at 60F, and the fan on "High", but it would run real slow. After a few weeks, the blower started to run only sporadically. It would quit for a while, then come back. The quitting SEEMED to be associated with accelerating. Now the blower has quit completely, but the compressor still runs and the dampers function. When the car is moving, I get a little bit of cold air trough the registers; none when I'm stopped.

Can you help? Thanks."​

I got one response suggestiong that the blower motor was shot. I took it to a mechanic who diagnosed it as a failure of the the AC Programmer. So, I replaced the $700 AC Programmer (didn't pay that much, though) and everything worked fine for about 2 weeks.

Now it's doing the same thing; blower on sometimes ( a small fraction of the time) and off most of the time. The programmer is indeed controlling the path of the air (vents on "Auto" and dash on "Defog") but the blower is not running (usually).

I have searched this forum and it looks like others have had a similar problem. Has anyone founs the solution?

Thanks.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,973 Posts
Check the plug to the blower for a burnt connection. Try wiggling it and see if it starts to work.
 

·
Registered
97 DeVille Concours
Joined
·
22 Posts
I second Rangers suggestion.... I had the same problem, and it was the plug to the blower motor. I have replaced the blower though, so i must have pulled one of the terminals loose.
 

·
Registered
Ex-99 Deville and 04 DTS owner. Now 05 DTS and 07 Audi S6 owner. 5.2L V10 power!
Joined
·
864 Posts
I think it's ur blower too. I had to replace mine. The motor burns out after all them years. The AC programmer controls the vent operation only if I'm not mistaken. Blower motor does it's own thing from the AC programmer. But yea, it's probably the motor. If it comes on and off it probably the connectors, but they might be corroded and need replacement(then u just have to replace the whole motor)

)
 
1 - 5 of 5 Posts
Top