Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
2003 CTS(Sold) Black 09 V
Joined
·
457 Posts
Discussion Starter · #1 ·
So....Neither does my heater nor AC works now. I am in England and my car was in transit from the US for the last 1.5 months. The shipping company did say the battery died while they had it. I checked the fuses and nothing. I disconnected the battery and stepped on the brake.. nothing. I checked under the hood for loose connections, nothing. I called cadillac USA...nothing. they could even find me a dealer nearby in the UK.. Its Saturday and most of them are closed anyways. Its cold out here so its not convenient to go around without this working. I can feel a hint of warm air thats all but nothing else. Please help!







e help
!
 

·
Registered
Had 2009 V, Red/Blk 2016 Now
Joined
·
4,186 Posts
"I disconnected the battery and stepped on the brake and nothing"; what does this mean? Did you check the trunk connections since they messed with it? Do continuity checks from the trunk/battery to the front. What's the battery voltage? If it starts, what is the battery voltage while the alternator is charging then? Recheck the manula for ALL the fuse/circuit breakers too. I thought that the main circuits had multiple ones.
 

·
Registered
2003 CTS(Sold) Black 09 V
Joined
·
457 Posts
Discussion Starter · #3 ·
ill check the voltage as i haven't yet....some friends told me once u disconnect the battery to step on the break to reset the ECU or something like that done know how true that is. I doubt the core unit went out and have a feeling its a easy fix but hopefully im right. I still can only feel a hint of air coming thru the vents but not enough.
 

·
Registered
2003 CTS(Sold) Black 09 V
Joined
·
457 Posts
Discussion Starter · #4 ·
Battery is good (14.8 volts). Fuses are good so must be some kind of bad ground I'm guessing.
 

·
Registered
Joined
·
4,150 Posts
A heating system works by diverting hot coolant through a heating grille where it warms up air which the fans blow in whichever direction and whatever speed you specify.
Basically there are two parts to the heater system, there is the heater tap, located in the engine compartment. It controls how much (if any) hot coolant goes through the heating system in your car.

Probable causes are a leak in one of the hoses, the heating grille itself (you will smell coolant in the car) of the radiator is not sufficiently topped up with enough coolant to circulate through the system. If not turn your heater on to full, turn your car on for a short while, turn it off and top up the coolant. Also bleed the air out of the system if necessary.
 

·
Registered
2017 CTS-V
Joined
·
338 Posts
Does the fan operate in manual mode? If it does it might be the HVAC controller. Do any of the lights light up on the heater display? Does the rear window defogger light come on? When you switch from different settings does the air switch from the vent, to floor to defrost?
 

·
Registered
2003 CTS(Sold) Black 09 V
Joined
·
457 Posts
Discussion Starter · #7 ·
Everything works except the fan.. I can feel the heat coming thru the vents but only when the car is moving...The faster I go the more I feel it. All the controls look and operate as normal...Only thing is the fan not working from what i can see.
 

·
Registered
2010 CTS-V, Black Raven
Joined
·
34 Posts
I had a GM SUV at work with the same problem. I got down beneath the corner of the console where the fan housing is and just smacked the fan housing. Either a dead spot in the fan winding or something was stuck, no problems since.
 

·
Registered
Joined
·
826 Posts
I had a GM SUV at work with the same problem. I got down beneath the corner of the console where the fan housing is and just smacked the fan housing. Either a dead spot in the fan winding or something was stuck, no problems since.
Had a Harley Sportster that needed a well placed kick from time to time...this is old school wrenching...but it worked for me for years!!! :yup:
 
1 - 10 of 10 Posts
Top