Cadillac Owners Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all. I had a small problem with my first generation cts i was driving normally going home and then the alarming sound comes on (3 beeps) and i check the control center nothing is on it when i checked the dashboard the ABS light was on, but the weird thing that if i turn the car off it would go away then after a while it would come back on so i decided to check if my ABS is working and it is but the light keep coming up. Any suggestions of what i should do? Thanks in advance.
 

·
Registered
2007 CTS 3.6 >137k miles
Joined
·
978 Posts
^this
Gotta know what is going on before it can be fixed.

Also, the ABS system requires a good connection below the seats. After 10+ years in service, connectors sometimes collect dust etc and the connection is intermittent. This happened on my CTS and fortunately was an easy fix. I just disconnected the plug under each seat, applied dielectric grease to the contacts and plug seals, and reconnected. Problem solved. As with all electrical work, disconnect the neg battery cable first. YMMV.

***edit: I misread this as an airbag light instead of brake system. The underneath connectors are necessary for airbag but possibly not the brakes. Nevertheless it is worth checking connections at the wheel hubs.
 

·
Registered
2005 CTS 3.6L V6
Joined
·
67 Posts
As others have said, the first thing is to plug in a scanner and see what codes come up. Does ABS still work while the light is on?

Are you sure the BRAKE and TC lights didn’t also turn on? The only code that turns on the ABS light without either of the other two is B0665, which indicates Instrument Cluster or EBCM failure, or bad wiring.

Also it could just be a bad fuse, there’s one under the hood and another in the rear underseat passenger side fuse block.
 
1 - 4 of 4 Posts
Top