Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
1990 Brougham
Joined
·
105 Posts
Discussion Starter #1
since i bought the car, they never worked. lets try to ignore ive been driving without working wipers since september. its not dangerous, its just challenging. anyway i replaced the motor today, had to learn to solder on the fly. but its all in properly, my neighbor confirmed this. the plastic bit on the front of the wiper motor full of electronic things i dont understand seems to be the problem, we tested all the wires and somethings wrong with that part. anyone know an easy fix for this? if not im going to a junkyard and just getting yet another wiper motor. (the remanufactured one i bought came without the plastic part.)
 

·
Registered
70 Deville 77 Fleet 78 Seville 92 Deville 03 Deville
Joined
·
3,310 Posts
The plastic part is the part that usually screws up so definitely go to the junkyard and try to get a good one.
 
D

·
Guest
Joined
·
0 Posts
Theres something wrong with my wipers aswell!

When turned on, they will NOT turn off no matter what setting until I turn the car off...

Do you guys know what could be the problem?
 

·
Registered
84 Coupe w/500
Joined
·
5,665 Posts
Those problems are in the electrical circuitry in the plastic part. Just get a new one because they are cheap enough, dont get a used one because its probably as old as the one you have now. The service manual actually tells you how to test the circuit board but its just not worth it to me. Rockauto would have one for pretty cheap.
 

·
Registered
1990 Brougham
Joined
·
105 Posts
Discussion Starter #5
thats an amazing list of parts. its simple and works, just like everything should be. thanks for the website, gonna bookmark it for future use! but i think i can order the remanufactured part thru a local shop cheaper.
 

·
Registered
1989 Fleetwood Brougham d'Elegance|2018 Chevy Colorado Z71
Joined
·
6,421 Posts
That little circuit board manages timing and operation of the motor for the Wash, Mist, Delay, Low, Medium, and High speeds. Mine stopped working right a year or so ago but I got lucky with one at a junkyard. I took like 5 or 6 home and the first one that worked properly I left in the car. My wipers used to not work on the Wash, Mist, or Delay settings. They would creep up from their hide away place for a second then go right back down. They worked on the full motion settings but wouldn't turn off unless the car was shut down completely. So that little circuit board can cause a variety of little problems. My wipers did some funny shit that me and my friend laughed about when we tried some of the bad boards we took home......
 

·
Registered
1991 Cadillac Brougham D'Elegance 5.7 Litre, 1994 DeVille
Joined
·
6,796 Posts
Theres something wrong with my wipers aswell!

When turned on, they will NOT turn off no matter what setting until I turn the car off...

Do you guys know what could be the problem?
Every time mine's done that it's because of the windshield wiper pump. Does it make any strange noises or try to squirt windshield washer fluid?
 
1 - 7 of 7 Posts
Top