Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I just installed a system im my 96 Fleetwood Brougham, (using the stock radio). After putting the dash back together i relized the A\C is just blowing hot air even with the controle reading 60 degrees. The compresor kicks on and gets cold but there is no no cold air coming out the vents, i checked the vacum lines the best of my abillity, and have no other guesses, Please help its January in Tx and i need my A\C
 

·
Registered
1994 Cadillac Fleetwood Brougham (some show and some go!)
Joined
·
607 Posts
Never dug into the duct system and the works under the dash of my FW but to me your problem sounds like a cable issue if the FW is equipped with it. Like a flapper door that switches between air from the ac system or hot air coming off of the heater core.

Regardless, it sounds like it is something affected when the dash was removed/reinstalled. Hope you track it down.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Thanks for reply, i also think it might the flapper door. Do you know where it is located? i really dont want to tear the dash up any more, ( it was hard enough going in there the first time).
Thanks Again.
 

·
Registered
1994 Cadillac Fleetwood Brougham (some show and some go!)
Joined
·
607 Posts
Nope, sorry.

I suggest getting a factory service manual. It's a book a tad thicker than a big city phone book full of diagrams, flow charts, how-tos, and everything else on a vehicle. Good stuff, about $90 at Helms (helmsinc.com or .net I think) but well worth the cost!
 
1 - 4 of 4 Posts
Top