Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
97 ETC, air conditioning has been erratic, sometimes works fine, sometimes doesn't work, sometimes works then stops and then works again. Have had at two shops that say they could not duplicate the problem, that I will have to bring it in when it is faulting so that they can diagnose the problem....but one has said blower motor and that the cost would be 450.00, but will not do it until they can prove it with their instruments, because there is a 10% chance that it is not the blower motor! On OBD, I get B1312, A/C High Side Temperature Sensor Open! Any help is appreciated.:cookoo:
 

·
Registered
Joined
·
28 Posts
Make sure your spark plug wires do not touch the blower motor. The electrical frequency from the ignition spark will kill the blower motor (actually the module located inside. Almost sounds like you may have a lose connection or a sensor going out. Check all your A/C related connections under the hood. Note, the A/C module is located inside the blower motor.
 

·
Registered
Joined
·
19 Posts
Is that true,that the plugs will kill blower motor. I just put in blower motor yesterday work fine ,the next day not working . I tapped the blower with a screw driver working again .Then it will start again.How do i shield the blower from plugs . They live acorss the street from each other .

97 concours said:
Make sure your spark plug wires do not touch the blower motor. The electrical frequency from the ignition spark will kill the blower motor (actually the module located inside. Almost sounds like you may have a lose connection or a sensor going out. Check all your A/C related connections under the hood. Note, the A/C module is located inside the blower motor.
 

·
Registered
Joined
·
19 Posts
I have watching these post in order to fix my own problem with the blower motor. I had the same problem with it working , first with ac late sept.- october november it quit just in time for winter. A month later saved uo for my 90K fixer upper caddy dealer took a look said blower had open on it had repace. Saved another month bought the 252$ part for cost @ newgmparts.com thats if you likepaying dealer prices. Then had my local mechanic change it for 65 labor. Would did it myself , if NYC wasn't in the middle of a storm. It worked 2minutes after installing ,drove home and parked it .The next day read some post then went to remove some snow from car with pure heat. No dice won't work came in and read you guys post about spark pugs etc.Went out to insulate it somehow . While checking it i disconnected the male plug from the new blower looked at it. Could easily see where the neg wire was burnt. cleaned off and saw thatthe connector pin was pushed down the explaining working on and off, or hitting it .Bent contact a little and on came the heat. That making on&off contact would soon later burn out your blower.
I like to thank you for making realize that i could have fixed this before [email protected] cost .

gmcnaples said:
97 ETC, air conditioning has been erratic, sometimes works fine, sometimes doesn't work, sometimes works then stops and then works again. Have had at two shops that say they could not duplicate the problem, that I will have to bring it in when it is faulting so that they can diagnose the problem....but one has said blower motor and that the cost would be 450.00, but will not do it until they can prove it with their instruments, because there is a 10% chance that it is not the blower motor! On OBD, I get B1312, A/C High Side Temperature Sensor Open! Any help is appreciated.:cookoo:
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
5 Participants
xeper
Top