Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Cadillac
Joined
·
1 Posts
Discussion Starter #1
On a 1995 Cadillac Sedan Deville, after the dealer replaced the water pump, the air conditioning is not blowing cold air and sometimes no air at all from the front vents. Before they worked on it, the air conditioning worked great. It does NOT appear like the clutch on the compressor is engaging when you turn the a/c on. Any advice or input would be greatly appreciated.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,986 Posts
The compressor is disabled to prevent self destruction if the refrigerant level gets too low. Start by pulling the DTC's by simultaneously pressing and holding the OFF & WARMER buttons. Decipher the DTC's here. http://myweb.accessus.net/~090/dtcobd1.html
Compressor clutch not engaging leads me to think low refrigerant. No air from the vents leads me to think blower motor failure.
 

·
Registered
Cadillac
Joined
·
4 Posts
the same exact thing is going on with my '95, the compresser is not coming on at all and needs to be replaced =[ i've gone all summer without air!
 

·
Registered
Cadillac
Joined
·
4 Posts
The compressor is disabled to prevent self destruction if the refrigerant level gets too low. Start by pulling the DTC's by simultaneously pressing and holding the OFF & WARMER buttons. Decipher the DTC's here. http://myweb.accessus.net/~090/dtcobd1.html
Compressor clutch not engaging leads me to think low refrigerant. No air from the vents leads me to think blower motor failure.


...my digital screen also reads "very low refrigerant" when i try to turn the air on so you are probbably right
 

·
Registered
Cadillac
Joined
·
60 Posts
My 94 Deville is doing the same thing, Mine is saying "Low Refrigerant" but it won't let me add any to it. I don't know why. I had ice cold air and now I have none at all. Compressor has 172,000 miles on it I guess I will half to replace it with a new one.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,986 Posts
My 94 Deville is doing the same thing, Mine is saying "Low Refrigerant" but it won't let me add any to it. I don't know why.
Because the compressor is disabled. Enter the onboard diagnostics and clear the DTC's. That will enable the compressor and allow you to add refrigerant.
 

·
Registered
91 sedan deville
Joined
·
341 Posts
If clearing the codes don't work try this. On the accumulator located by the firewall pull the connector in the back of the accumulator and get a paper clip and stick it in between the connector, in order to jump the compressor so that you may add freon to it. I had to do this to my a/c on my 91 cadillac deville 4.9L. Then when your done simply unplug the paper clip and insert the connector back to the accumulator pressure sensor.
 

·
Registered
Joined
·
165 Posts
You could also crear your codes by disconnecting you battery and letting it sit for about 10 mins. Once you reconnect the battery, connect the hose to the low side with the valve off. Start the car and turn the A/C on on the lowest temp setting at the highest blowing level. You should hear or see the compressor clutch engaging and see your gauge on the 134a go down because it is pulling the 134a in. Keep it within the right level. If you use those cheap gauges on the can, it will be a blue area. Good luck.
 
1 - 8 of 8 Posts
Top