Cadillac Owners Forum banner

1 - 13 of 13 Posts

·
Registered
EXT
Joined
·
88 Posts
Discussion Starter #1
Can I just use one of those $40 advanced auto freon recharge kits or does this truck need something else ?
02 6.0 AWD
The feet comes out at feet, defroster at defroster, vents at vents, etc..but it's blowing HOT air with a/c on, auto setting on, anything and it's blowing hot, and it's only like 60-70deg outside, air from vents feels like 80
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Try resetting the system
Pull the hvac fuse for a minute then put it back in and turn the key to run and let it sit(engine not running) and report back

----------

Also is it just one side or both sides??
 

·
Registered
EXT
Joined
·
88 Posts
Discussion Starter #3
Will do thanks ! I belive its both sides I will double check
Wich fuse is the hvac ? Under hood box ?
Thanks !
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Yes it is labeled hvac1 and is in the under hood fuse block

I would also check the ac compressor relay while I was at it(it should click when the compressor is engaged)
 

·
Registered
EXT
Joined
·
88 Posts
Discussion Starter #5
Ok I did what you said..
When I put the key to run the AC blows semi cold for about 15sec then gets warm.
When I start the truck and put AC on it blows hot immediately.
When I click on the AC button I hear a faint click, hear compressor run louder, hear/feel slight difference in motor...

----------

(I pulled and put back in the Front HVAC fuse and the AC fuse/relay)
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Ah ok I would get a ac guage set and check the pressure levels as it may be low

I wouldn't trust those refill cans I ain't saying they won't work I am saying it's just risky of overfilling the system with them
 

·
Registered
EXT
Joined
·
88 Posts
Discussion Starter #7
Gotcha...thanks !
Might just bring it somewhere and ask to check level and fill I guess since I don't have the gauges
 

·
Registered
EXT
Joined
·
88 Posts
Discussion Starter #9
Been so damn busy with work, etc..haven't taken it anywhere yet but now it's just blowing hot air at all times pretty much..with system on off it's just putting out hot air. Even to rear..center console is like a microwave. Pretty annoying since it's like 90deg and 80% humidity this week.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
That sounds like a sensor is bad

I would check the actuators with the blower off to make sure any are bad first

A tech-2 can access the sensor data in order to tell if a sensor is bad
 

·
Registered
2003 Escalade ESV
Joined
·
41 Posts
Check the A/C compressor belt. I thought my A/C system was toast the other day (i thought maybe i overcharged the system from using a recharge kit with no gauge, and broke it) when I was driving. I checked around and saw my A/C compressor belt snapped.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Dubbalade said:
Check the A/C compressor belt. I thought my A/C system was toast the other day (i thought maybe i overcharged the system from using a recharge kit with no gauge, and broke it) when I was driving. I checked around and saw my A/C compressor belt snapped.

+1 I recently had to replace the ac belt on my truck later as it was near snapping
 
1 - 13 of 13 Posts
Top