Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
when a/c is blowing cold and temp. is increased the unit go to the econ. mode. to make it work I have to disc. battery teminal and resset computer any help or ideas? by the way I am a new user, great site.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,778 Posts
:welcome:When the system defaults to ECON mode it is usually because it is low on refrigerant. You should be seeing a Low Refrigerant warning. I would also expect there to be a DTC (diagnostic trouble code) stored. Pulling battery power is clearing the codes and thus enabling the compressor til it trips off again.

Enter the onboard diagnostics by simultaneously pressing and holding the OFF and WARMER buttons til the DIC lights up all segments. Any stored DTC's will then be displayed. Be prepared to write them down.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the reply and I think I have two problems. The a/c cpmpresser does not trip off and will continue to blow cold air until I increase the temp to about 75 and the system goes to econo. I do get a service a/c light and will pull the codes as you suggest and get back with you. Thanks again :cool2:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I think I did it righr and I pulled the following codes: E52 and F46. Are these valid codes and if so can you tell me what they are? Thanks...:cool:
 

·
Registered
88 Sedan Deville, 89 Eldorado, 11 SRX, 18 CT6
Joined
·
130 Posts
52 is cause you disconnected n reset battery. 46 is low side sensor AC. your most likely low on freon. i would STOP disconnecting and reconnecting battery to get ac... as its DESIGNED to prevent you from killing your compressor... ( EXPENSIVE REPAIR ) just because you need freon. to help further, where are you from... and what year / make is the car. if it's R12, it's still available, if its R134a its readily available.... no reason to keep it low like that.
 
1 - 6 of 6 Posts
Top