Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Cadillac 99 STS
Joined
·
40 Posts
Discussion Starter #1 (Edited)
Ok I do have a code:
B0130 - Air Temperature/Mode Door Actuator Malfunction

My drivers side alwasy blows hot no matter where the temp is set. It also doesnt seem to change from floor to defrost no matter where its set. I am going to replace the actuator. I have varified it does not move when the temp stuff is changed( bear to get at) But i have a couple questions for those in the know.

I see one acuator on each side, does the SINGLE acutator control temp and where the air blows? I can see it doing one or the other, but both?

Second question I have just the one code, nothing else at all, but MY AC isnt working, I'm assuming it needs a charge, simple, i have done this alot, but I keep hearing to clear codes. I have no codes, could the air not be working from the acutator door not working, hence the AC isnt allowed to come on? Passneger side works fine (aside form not blowing cold, but no ac pump, no cold air). Also i hear reset the AC (or reset the codes?) which is it, for recharging?

Reason I'm asking is , to get that drivers side Acutator out Im tearing alot of stuff apart, and if there is another Door i need to look at now is the time. My STS is black, and living in ND, i have been lucky no heat (or unlucky i guess) but its starting to creep inot the low 70's now.. and black warms up quick. So far no worries, i got windows.. but soon the actual heat will be here.
 

·
Super Moderator
2010 DTS
Joined
·
87,572 Posts
No, there should be an air mix actuator and a mode actuator.

The actuators have nothing to do with the compressor. Check to be sure that no one unplugged the compressor clutch.
 

·
Registered
Cadillac 99 STS
Joined
·
40 Posts
Discussion Starter #3
I seen GM parts direct has them for a fair price ($120 shipped), was down Local GM in town and they wanted $300!!! But they where kind enouhg to supply me with a Parts diagram/breakdown so I see there are two on each side (the right side, one is defrost). I did get it out and see i have a split gear. I'm going ot try and repair it. Its a pressed on friction fit gear so its going to be touhg to glue/repair so it holds. The gear has some groves so it may be possible with the right glue/epoxy. I am thinking of some small holes drilled and maybe some JB weld (that stuff has made some mairacles for me before). Going ot take a stab iat it this weekend, try take some photos if it works and show others.

One last question, since there are two on each side, and GM parts direct just lists Left and right side, are they the same two on each side? anybody know?
 

·
Registered
98 STS
Joined
·
295 Posts
let me know the outcome of your project, i'm having the exact same problem to the T, no air etc defroster etc, plenty of refridgerent in the system.
 
1 - 4 of 4 Posts
Top