Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
99 seville sls
Joined
·
2 Posts
Discussion Starter #1
car starts and idles smoothly for about 10 - 15 sec. then shuts down. Can restart by pumping the fuel pedal for about 10 sec. with engine running but very rough, then rpms shoot up to around 3000, slowly comes down to idle and car drives fine.
I
I've cleaned idle air valve , throttle plates,and mass air sensor,but still does the same thing. Anyone got any new ideas?
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Pumping the throttle on a fuel injected car doesn't accomplish anything. That was a way to get extra fuel into the engine via the accelerator pump on carbureted engines.

Have you pulled the codes?

How did you clean the TB?
 

·
Registered
2002 STS, 2005 CTS 3.6
Joined
·
413 Posts
Take the IAC apart and clean it good as mentioned in other threads here. Always check PCM codes first.
 

·
Registered
99 seville sls
Joined
·
2 Posts
Discussion Starter #4
Cleaned iac with electrical parts cleaner approx. 3 weeks ago, athe same time cleaned throttle body with b-12 chemtool. Engine starts immediately and holds proper rpm's for idle for 15 sec(+/-5] then shuts down like key was turned off. Can re-start immediately but have to keep pumping throttle to keep rpm's above 1000/1500. I know it's fuel injected, but you can't hold steady pressure on gas pedal without engine dying. After another 10-15 sec, rpm's shoot up to 3000, then slowly wind down to idle speed and car drives fine until next ignition sequence. Two days ago I tried starting and immediately bring rpm's to 1500 and holding for 20 sec and engine runs perfectly, when throttle is released and rpm's drop back to idle. Last pulled code was P0101, [MASS AIR] , so I cleaned with spray specific for that application, but I have trouble believing problem is with mass air since I replaced that part 18 months ago due to occasional missing at cruise and on acceleration. After all that, ANY ideas ?
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Was the replacement MAF new or used? What brand? Did you inspect the wiring/connector?
 
1 - 5 of 5 Posts
Top