Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
Cadillac
Joined
·
8 Posts
Discussion Starter #1
I have a 99 seville sts, lately its been giving me all kinds of trouble codes.
Installed a new battery and checked alternator voltage. when i get to around
2000 rpm it says battery not charging, air bag needs service, traction control,
also when this happens the windows don`t work the ac quits working i`m at a loss. Any advice would be appreciated, Thank you.
 

·
Registered
Cadillac
Joined
·
8 Posts
Discussion Starter #6
Also i put a volt meter on the battery and when reved to 2000 rpm i got 17volts is it possible the new battery i got is bad? every time it whent to 17volts the messages came back.
 

·
Registered
'98 STS (RIP @ 206,xxx miles)
Joined
·
4,854 Posts
Take it to an aftermarket parts house and have your alternator tested. Your codes all indicate an alternator voltage problem.

Most folks would NOT recommend installing an aftermarket rebuilt alternator. If yours tests faulty, have a GM new or rebuilt installed.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
69,116 Posts
A "normal" 12v battery, at rest and unloaded for more than 2 hours, should read 12.6 volts fully charged. The battery is dead when it reads about 11.9 volts under the same condition. Your panel info should indicate 13.9 to near 15 volts when charging, depending on electrical loads in use. Over 15 volts or so indicates overcharging, and that's an alternator/regulator problem. Do your headlights get brighter and dimmer with engine speed? The brightness should stay very close to the same, regardless of engine speed and load....
 

·
Registered
2008 SRX
Joined
·
403 Posts
You have a loose connection between the alternator and the rear junction block on the positive side. Check battery cables and junction block connection. Just a guess..
The 99 also has a battery thermistor at the rear junction block, but I think if that fails it won't charge.
 
1 - 11 of 11 Posts
Top