Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 98 sts is running very rough when starting cold. it has a new fpr and new plugs and wires. none of those things helped at all. no codes are showing. when the car reaches temp it smoothes out. any info would be greatly appreciated.
 

·
Super Moderator
Joined
·
86,082 Posts
Get a mechanics stethescope and listen for arcing in each of the coils. If you hear any, it would be suspect. Or try swapping them out one at a time with a known good one to eliminate a coil.

Check to be sure the plug wires are good and tight and snapped on to the plug. Check for carbon tracking down the side of the plug. It may appear as a cracked insulator.

Be sure the wires are routed correctly.

Use the stethescope it listen to each individual injector when it is running rough. You will hear it clicking as it opens and closes. A silent one would be suspect.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
all ignition connections are good all injectors working. I am thinking of just replacing the entire coil pack and the ignition control module. I can get them all new for $140.00 would the car warming up change the way that the igintion worked though? it only runs rough when cold
 

·
Super Moderator
Joined
·
86,082 Posts
I suppose it is possible that when it is cold a contact contracts and looses positive contact and when it warms up it expands and makes positive contact. That said, throwing parts at it can get expensive if you are wrong.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
Ranger
Top