Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I had my car tuned-up recently. I had the surrounding area of the egr valve cleaned out; replaced the air filter; and had a oil change. However, my car is stalling at just about every stop sign. If the car is in park, its fine, but if i am at a stop light with my foot on the break too long, it will stall.. Any ideas of how to fix this problem?
 

·
Cadillac Owners Connoisseur
Joined
·
1,164 Posts
FamilyCaddy said:
I had my car tuned-up recently. I had the surrounding area of the egr valve cleaned out; replaced the air filter; and had a oil change. However, my car is stalling at just about every stop sign. If the car is in park, its fine, but if i am at a stop light with my foot on the break too long, it will stall.. Any ideas of how to fix this problem?
Hi FamilyCaddy and :welcome: to Cadillac Forums!

It sounds like it could be a number of things. First suspect in my mind is the crankshaft position sensors. They are commonly the cause of a problem just like that. Also in question is the state of the throttle body. It probably needs to be cleaned up along with the throttle blade. If you use the Search feature above and look for clean throttle body, you'll find all the information you need to clean it and eliminate that as the stalling problem. The last thing in my mind is the Idle Air Control valve, which may also be crudded up with the same stuff in the throttle body or the valve could just be failing. Are there any other codes? Does it start, run, and drive fine except for the stalling? What is the idle speed? Have you noticed that the accelerator feels a little sticky sometimes?

Let us know and someone will probably be able to tell you what's going on and how to cure it. :welcome:
 

·
Cadillac Owners Connoisseur
Joined
·
1,164 Posts
We need a little more information to help diagnose the problem, mostly the codes and what is the idle speed? It does seem like crankshaft position sensor problems, but we need to know a little more to be more accurate.
 

·
Registered
2008 CTS 3.6DI AWD
Joined
·
932 Posts
Hi, I'm a long time reader and haven't posted much yet but now I have a similar problem. I have a 1998 Seville SLS about 105,000 miles. First time it stalled was coming off of a highway(slowing from 70 mph to 30 mph). Took it to the dealer and they pulled the code P0741 - TCC System Stuck Off and said that the solenoid was sticking and needed to be replaced. Everyone i called so far has said between $2500 to $4000 to replace (i could do the whole tranny for that much!!:want: ) even though the part is only $40 from what i understand.

After that i cleared the codes and it has stalled about 4-5 times in a 3 week period, mostly coming to a stop or slowing down from 45 mph. This happens when the rpms drop below 500. I have seen it drop, once or twice, below 500, some lights come on but the car doesn't stall, like it catches itself. i pulled the codes today and the only code on there was P1599 - Engine Stall or Near Stall Detected (no solenoid/TCC code:eek: )

My car runs great, doesn't run rough, no leaking, good mpg, great acceleration. When it stalls everything keeps working;radio, lights on dash. The car starts right back up after stalling.

I plan on cleaning the throttle body tommorow
 

·
Registered
2008 CTS 3.6DI AWD
Joined
·
932 Posts
ok...i cleaned out the throttle body today(man was that dirty). I drives so much better now and does not drop below 600 when downshifting (which is a good thing). I will keep you guys updated. Cleaning the throttle body is probably your best bet on eliminating stalling.
 

·
Registered
2008 CTS 3.6DI AWD
Joined
·
932 Posts
nope didnt work still stalled again. Im gonna try cleaning out the egr valve this weekend...any other suggestions?
 

·
Registered
1996 Cadillac Fleetwood Brougham
Joined
·
4,414 Posts
Just have RPM increased up to 900 when in Neutal . I did that way and get rid of the problem forever or up until I sold the car ('96 STS ) .Only problem -if it's a problem- SES came on when increasing the RPM when idling . Anyway that light was gone after a while
 

·
Registered
2008 CTS 3.6DI AWD
Joined
·
932 Posts
Just have RPM increased up to 900 when in Neutal . I did that way and get rid of the problem forever or up until I sold the car ('96 STS ) .Only problem -if it's a problem- SES came on when increasing the RPM when idling . Anyway that light was gone after a while
just to clarify: how long did u keep it at 900 rpm and how many times did you do it (every time you started or once a week)?

Thanks
 

·
Registered
1996 Cadillac Fleetwood Brougham
Joined
·
4,414 Posts
Just once :)
As I recall, I kept the car one year or so after that cherry cake job and with no stalling problem .Any mechanic should do that even shade tree ones lol
The car was good enough to keep that RPM

Good luck :thumbsup:
 
1 - 12 of 12 Posts
Top