Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I’ve gotten ahold of a beautiful black 98 DeVille Elegance with only 69,000 miles on it. The car drives great on the highway and most short distances, but there have been 2 times where the engine has overheated (240 degrees or over) once while stuck in traffic after being on the highway, and the other in a drive-through. Since then I have been very careful about sitting too long at stoplights if I can help it, etc. The one thing that stops me from thinking it could be the head gaskets, is the way it only overheats when it idles for long periods of time, and the fact that the ac works, but the heater doesnt (possible radiator/fan issue?). I love this car, and will do whatever I have to in order to fix it. You guys are my last hope as the past two mechanics I have taken it to hear the words “running hot” and “northstar engine”, they tell me they don’t want to deal with it or can’t.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,184 Posts
Check the purge line to be sure it is clear and flows coolant. Check it after a cold start for safety reasons.
If it is clear and flows coolant, do a block test to rule out the HG's.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
69,837 Posts
Purge line, and here's your pre-2000 cooling fan schematic.

If no A/C compressor function is set - in traffic or at idle - fans go to SLOW at 224 degrees; FAST at 236 degrees - the engine cools to 213, fans turn off, cycle repeats. With A/C set fans run in SLOW all the time. They usually don't run at over 30 mph - not needed.

To rule out the remote possibility of failing head gaskets (caused by cylinder block head bolt hole thread failure, NOT bad gaskets) perform a cylinder block exhaust gas test. Rent the tester from any parts store or buy your own on Amazon - Lisle #75500.


fan control circuit-early.gif


The heater doesn't work - no warm air or no air at all? With the engine warmed up check the heater coolant supply and return pipes - they should be HOT. If the inlet is warm and the outlet is cool(er) then you may have a clogged heater core, possibly due to excessive use of cooling system sealants.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
The heater briefly worked, and now the only hot air I feel when its on full blast is from the front defrosters
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
69,837 Posts
Sounds like air blend/mode door actuator problems.
 
1 - 5 of 5 Posts
Top