Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just picked up a 98 Deville with only 70,000 miles on it! I’m having some strange wiring issues though, sometimes when I start the car it’s fine for a couple minutes, then out of nowhere I get flashing lights around my dash, and a theft system problem pops up that tells me car might not restart, as well as the radio shutting of and not coming back on. I’m not sure where to start, has anybody dealt with this before?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
67,924 Posts
Welcome to CF !!!

If the head unit has been replaced or is aftermarket there's a chance that it is not compatible or set up to correctly "talk to" the security or serial data bus systems.

All wiring diagrams and sound system wiring is in www.alldatadiy.com or in the GM/Cadillac/Helm service manual set - ebay.

The car has its own built-in trouble code scanner/memory. Learn how to use it by studying the correct model/year section of the sticky post "How to pull codes". Use the embedded link to all OBD-II trouble codes to decipher any found codes and post it all here.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you!!
It is the original radio, I’ve tried pulling codes and only a few “history” codes would come on before my car would again go black and radio would shut off, then the codes would come back and just say no data.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,059 Posts
sounds like a faulty GROUND -
 
1 - 5 of 5 Posts
Top