Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Catera
Joined
·
2 Posts
Discussion Starter · #1 ·
I searched all through the forum looking for a hint but cannot find anything. long story short when I start the car and let it warm up i get heat, go for a drive it will start blowing cold (when driving at a constant speed) accelerate quickly and starts blowing hot instantly, let off goes cool again within 10-20 seconds. will continue doing the same thing over and over. turning the temp knobs when idling the driver/pass work perfect so i dont think its the actuators.is there another blend door in the heat/ac system? the other issue is the temp gauge, it will climb while idling and while accelerating, when braking it drops to 0 accelerate again and it goes up. any help would be appreciated
 

·
Registered
Catera
Joined
·
2 Posts
hi i have 98 catera with same problem and i dont know what to do if you have any ideas can you please help or anyone on this site thanks
 

·
Registered
Catera
Joined
·
2 Posts
Discussion Starter · #3 ·
also found out that if im driving 60 or faster there is no problem with heat...drive 55 and it blows cold??? putt around town at 30 have heat..so between 30-60 i have no heat coming from vents. Had to go to a funeral 300 miles away and i did not have one problem other than i had to drive faster than 60 to stay warm. i really dont know what the problem would be so if anyone has seen or heard of something like this let me know please
 

·
Registered
Joined
·
6 Posts
It could be your secondary electric water pump. It's job is to keep water pressure up at low engine rpm's. Mine was not working and if I came to a stop or low idle situation air would blow cold. As soon as I pushed rpm's it would warm up.
 
1 - 5 of 5 Posts
Top