Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
97 seville sts
Joined
·
4 Posts
Discussion Starter #1
new at this.
i got a 97 seville sts north*
bought the car 2 weeks ago told had bad fuel pump.so i did not know anything about the car and the old owner was a ****ass ***:annoyed:
now that i put new fuel pump in fuel filter clean the fuel lines due to the sugar that was in the tank and kill the pump.The head gasket was bad.Fix all that and get a new battery and had to buy a new temp gauge since it broke taking the head off.Now that it is running fine and all the temp gauge goes from cold right up to half way point.no slow climb just jumps right up there.
so no clue on that and i check the temp with a I.R i have and every were is fine under 180 after running it.
And then the idle kicks up while i drive it when i am trying to stop and the temp gauge goes up and down but never over the half point.
Then to top it off the volts read on the dic say anywere from 12.1 to 13.9
depends how long i drive it.with lights on fan on high cooling fans on 11.5
but at the battery it reads 13.0 to 13.9 and everything off at the battery it reads 13.9 to 14.5
I have no clue were to start.
any help would be great
and i smell hot coolent when driving and standing in front of the car no signs of leaking.
thank you :confused:
 

·
Registered
97 seville sts
Joined
·
4 Posts
Discussion Starter #3
dtc
p0116 ect sensor
p0118 ect sensor
p0404 egr system
p0603 pcm memory reset
p1115 ect sensor ckt
p1599 engine stall


:hmm:
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,084 Posts
I'd start by checking the ECT sensor wiring. If that looks OK then probably a bad ECT sensor (which is more likely). Then pull the EGR valve and clean the pintle valve. They usually get carboned up and stick before they go bad. See the tutorial in the Tech Tips section.
 

·
Registered
97 seville sts
Joined
·
4 Posts
Discussion Starter #5
thank you i will do the egr thing this week.
the ect is new and wiring so far looks good .
i did pull the alt and will replace it just cuz it was a pain to take out and it does not cost that much for what you have to go thought to take it out.

while pulling the alt the wiring for fan relays was all bad.so i rewire all of them today and that will prop help with a lot of the dain when the fans turn on. the last ower did not bolt the relays downwhen he replace the rad
 
1 - 5 of 5 Posts
Top