Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
1997 Deville
Joined
·
83 Posts
Discussion Starter #1
Okay I have had a problem with my abs and tcs lights for a long while now, I have replaced 3 out of 4 wheel bearings, all except for driver side hub!! Now all codes have gone away but I am getting like a flutter in my brake pedal when stopping almost like anti lock brakes are pulsating is what it feels like and it shot a brief code of c1225 left front wheel excessive wheel speed variation!! So with that said if I go ahead and replace the driver side Hub will this delete this problem and the code??? Or am I pissing in the wind here?????
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,289 Posts
Okay I have had a problem with my abs and tcs lights for a long while now, I have replaced 3 out of 4 wheel bearings, all except for driver side hub!! Now all codes have gone away but I am getting like a flutter in my brake pedal when stopping almost like anti lock brakes are pulsating is what it feels like and it shot a brief code of c1225 left front wheel excessive wheel speed variation!! So with that said if I go ahead and replace the driver side Hub will this delete this problem and the code??? Or am I pissing in the wind here?????
-------------------------

c1225 left front wheel excessive wheel speed variation!!
yup - bad speed sensor in the hub -
we recommend ACDelco or TIMKEN hubs -
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,521 Posts
Check the electrical connections for cleanliness or moisture first - those wheel speed sensors each go to a main body harness - the pigtail connector sometimes loses continuity or gets corroded.
 
1 - 4 of 4 Posts
Top