Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
My SLS has been chugging, stumbling, and generally struggling; especially at low rpm in every gear. You guys have been saying over and over that after the fuel rail recall, many plug wire sets need replacing. Brittle etc. I was doubtful. Today the wire set came from GMpartsdirect(122.50 including shipping).
Now the wires are on and the MONSTER IS BACK!!! GREAT!!! Thanks a lot for all your experience.

TCO.:golden:
 

·
Registered
Joined
·
81 Posts
Discussion Starter #4
Funny thing, though. Checking the resistance, all were well in range for ohms. Only 1300 ohms on the short ones and maybe 3000 ohms on the three-footers. (Someone's posting here suggests 10,000 to 15,000 per foot is acceptable). But it must not be a resistance thing. It's more a breakdown of the sheilding, cause there were numerous discolorings where there was arcing to another wire or anything else they could reach.
The routing did seem to be correct. All clip-on space holders still there.
And get this...Both old and new sets were AC Delco and each new wire had ohm numbers 200 - 300 higher than the old one he replaced. Weird?

Thanks again. This forum is Money-in-the-bank.

TCO
 

·
Registered
White Diamond 2001 STS
Joined
·
1,317 Posts
Ditto -- had this same problem happen to me. Although the resistance checked out, and none of the original wires LOOKED damaged, apparently the dealer techs man-handle the wires and damage them somehow internally. Mine missed badly, especially in 4th gear, after the recall.

Glad to hear you got it resolved!
 
1 - 5 of 5 Posts
Top