Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
1996 Fleetwood Brougham
Joined
·
97 Posts
Discussion Starter #1
My Fleetwood suddenly has been starting hard. Checked fuel pressure and it drops to 0 almost immediately after I turn the engine off. Holds 32 psi while running. If I turn the key to run a few times it doesnt really come off of 0, but 3-5 times sends it to 40 psi for a second then back down. Am I looking at replacing the fuel pump or is there something else I should check first.
 

·
Registered
1996 Fleetwood Brougham
Joined
·
97 Posts
Discussion Starter #2
I just checked fuel pressure regulator. Pressure goes up to 42 psi when I take off the vacuum line and no gas leaks out.
 

·
Registered
Joined
·
388 Posts
The other thing that could go bad is the pressure regulator.
Sometimes the manual says to block off or pinch the return hose.
I remove the return hose and turn the key on only.
After a few tries if the pressure is not right or dropping right away and no fuel is coming out the regulator, then the regulator is doing the best it can by blocking the fuel return.

Not a bad idea to check you have a good 12 volts at the 4 wire plug near the filler. Sometimes grounds get iffy. But that would not cause your symptoms. Just good to check while you're there.

Fuel pump is common.
Something else to look for when doing the pump is the hose between the pump and steel pump line (in the tank).
Look for cracks, loose clamp, wrong hose, or kinking when moving the pump up & down.

My plastic hose was replaced by regular fuel hose not for fuel injection. so it was deteriorating.
Plus that pump housing has a spring loaded assembly that pushes the pump against the bottom.
The movement requires an extra loop of the factory fuel hose, that kinks a standard rubber hose.

Check also the electrical connections in the tank.

Best is to get the entire pump and float assembly new.
Spectra ST186 was good.
 

·
Registered
1996 Fleetwood Brougham
Joined
·
97 Posts
Discussion Starter #6
well now i only get about 15lbs of pressure from the new pump i put in. I put a new delphi fe0114 rated at 62lbs since I had it all apart. Any Ideas??
 

·
Registered
Joined
·
388 Posts
Hose may be kinking the pump hose when the pump is installed.
The pump is spring loaded to sit on the bottom, causing the pump to raise & tubing / hose collapse.
Just buy the entire assembly & be done.
 
1 - 10 of 10 Posts
Top