Cadillac Owners Forum banner

1 - 20 of 24 Posts

·
Registered
96 CADILLAC FLEETWOOD BROUGHAM
Joined
·
634 Posts
Discussion Starter #1
Low coolant light on, i topped off the overflow tank because it was low, so how do i get rid off the low coolant dash light? Or does it go off by itself? Any input please
 

·
Registered
96 CADILLAC FLEETWOOD BROUGHAM
Joined
·
634 Posts
Discussion Starter #2
I see the temp light kinda on? Meaning it not super red but medium red? Weird? I had replaced my thermostat due to over heating threw overflow tank now its fixed and lost some coolant, i tryed to fill threw thermostat hole but it was already to the top so i let it run a few to get the coolant flowing and the next day i noticed the overflow tank coolant was low so topped it off to try to get the light off so this where im at with it now
 

·
Super Moderator
2014 ELR
Joined
·
10,111 Posts
Re: 96 fleetwood low coolant light reset?

Smack it HARD with the side of your fist rapidly. The coolant reservoir. The sensor sticks. Ultra common.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
70,723 Posts
Re: 96 fleetwood low coolant light reset?

Engine coolant temperature gauges and lights are driven by the ECT sensor in the block or a cylinder head.

Coolant level (OK/low) is monitored by a sensor in the surge/recovery/overflow tank (depending on cooling system type).

There is no interaction between the two.

Unless there is some system that causes the temp light to glow with variable intensity based on coolant temp (highly unlikely) then a barely glowing light appears to be a bad connector, chafed wiring, or faulty temp sender.

That info would, along with the wiring schematics, be in the GM/Cadillac service manuals. www.alldatadiy.com or a paper copy from eBay.
 

·
Registered
1996 Fleetwood
Joined
·
491 Posts
Re: Temp light?

There is a sensor for the idiot light on the passenger side of the engine near the dipstick. It may have a bad connection, melted wire, or bad sensor. Unplug it and see what happens
 

·
Registered
96 CADILLAC FLEETWOOD BROUGHAM
Joined
·
634 Posts
Discussion Starter #12
Ok heres my other concern i been noticing on my 96,when i crank up my car at idle maybe 10 minutes my temp light seems like its slowly coming on but not as bright as the other lights on the dash? Does it work itself to get brighter when it gets hotter maybe? And what can cause this light to come on? Im thinking its my water pump but dont want to jump the gun? Any advice


https://pasteboard.co/IaDabmZ.jpg

Is the sensor up above by dipstick or down below


Moderator edit: Your two threads on the same set of problems have been merged into this thread. Let's keep all the questions and advice in one place.Thanks, Sub.
 

·
Registered
1996 Fleetwood
Joined
·
491 Posts
Side of the block, one wire you can't miss it. Sensor is probably bad, should be on or off.

Sent from my SM-G965U using Tapatalk
 

·
Registered
96 CADILLAC FLEETWOOD BROUGHAM
Joined
·
634 Posts
Discussion Starter #14
But how does a bad sensor slowly come on when car getting hot? Seems like its working but will try to locate it
 

·
Registered
1996 Fleetwood
Joined
·
491 Posts
But how does a bad sensor slowly come on when car getting hot? Seems like its working but will try to locate it
Well mine completely cooked the connector and the wire, but intermittent/poor grounding or a faulty sensor not completely closing a circuit could potentially cause that.

Sent from my SM-G965U using Tapatalk
 

·
Registered
1996 Fleetwood Brougham V4P
Joined
·
218 Posts
Hmmm. My temp light barely glows red all the time. Good to know it's not just mine. Any harm in just leaving it alone?...
 

·
Registered
1996 Fleetwood
Joined
·
491 Posts
Hmmm. My temp light barely glows red all the time. Good to know it's not just mine. Any harm in just leaving it alone?...
Not that I know of. But then again, after mine cooked the connector, I never fixed it. I like to live dangerously.

Sent from my SM-G965U using Tapatalk
 

·
Registered
96 CADILLAC FLEETWOOD BROUGHAM
Joined
·
634 Posts
Discussion Starter #18
Yea thought that was strange as well,but wonder thats a sign that something is bad right? Why evrybody asume its a bad temp light? I replaced my thermostat and cap, next will be change the temp sensor and if it the light still comes on i think its my water pump or radiator maybe?
 

·
Registered
96 CADILLAC FLEETWOOD BROUGHAM
Joined
·
634 Posts
Discussion Starter #20
It doesn't overheat at idle nomore, i havent attempted to take it out on a drive due to that temp light comes on slowely at idle after 10 minutes
 
1 - 20 of 24 Posts
Top