Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Noticed this first a couple months ago while the car was sitting in a McD's drivethru. All of a sudden, something seems to kick on, making a sound like an electric motor, and lasts for about 30 seconds. I thought it only did when the car was running until yesterday, when I was playing with my new satellite radio.

I had the key turned to on but car was off. Then bam, the sounds begins. It seems to be coming from the rear drivers side. It only lasts 30 seconds or so each time, and I just couldn't track it down. Not getting any codes, and the car is running great. I have no clue what this could be.
 

·
Registered
99STS,2004 Jeep Liberty Renegade,98 Deville RIP
Joined
·
1,054 Posts
I am not sure if your car has it, but there is a self leveling motor back there and it does make the sound you describe. If it was running all the time then you would have cause for concern. This motor pumps up your air shocks and keeps the vehicle level.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
Hrm...interesting. I'm not sure why I didn't notice it before a few months ago. Is it possible that it's running more often due to the shocks getting worn out?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,790 Posts
If it is running frequently, there is a leak in one of the lines most likely. The system bleeds down, and the compressor turns on to level the car and the cycle continues.
 
1 - 4 of 4 Posts
Top