Cadillac Owners Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
Alright fellas, hoping you guys can shed some light on this. I got a 95 SLS and the past few days its been stalling on occasion the last few days. Service Engine Soon light came on as well. While the car is in park the RPM go up and down and it tries going to 0 but then jumps back up. Its stalled a few times as i was taking turns as well. So, way home from work, i take a left and it stalls, then wont start. So i get a jump to see if maybe itll start up and i can get it home, and it starts up, The Engine light comes on but then goes off on the highway and the whole ride home the car shows no signs of wanting to stall, not even at stop signs. I turn the car on this morning and it turns on fine, no RPM jumping and no light. This seems wierd to me. I had taken my car down to get brakes and my mechanic said my car was stalling. This was maybe 2 months ago He pulled the codes and said that the codes traced back to needing to replace my EGR Valve. I havent done so because his estimate was like 500 to replace. Ive done some research and this stalling problem seems to have different options of problems such as a bad EGR Valve, Alternator,needs a tuneup, even 1 guy said he tried all of those things and it was a bad gas cap. This problem had occured a few summers ago and when i took it to a shop the mechanic said that my EGR valve had opened causing the car to stall. So idk what to think anymore. Ever since my mechanic said i need to replace the EGR Valve, the problem has happened, then it doesnt happen for a while and then randomly, like a few days ago it happens again. I want to sell the car before summer so i dont want to put alot of money into it. I hope someone can shed some light on this problem.

Thanks fellas.(its good to be back on the forum as well. I see alot has changed
 

·
Administrator
2002 F55 STS, 2014 Explorer XLT, F-150s
Joined
·
74,984 Posts
Go down to Discussions, Item Specific, Technical Tips and find one or more threads on EGR cleaning. Not difficult, if a bit of a PITA. You have 9 pages of threads to search, but it's all in there, several times.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
Well i replaced the radiator,tested the fans and they worked. However, i took it on the highway afterwards and the Service Engine Soon light still came on. I let the car run for a while and watched the Degrees Farenheit go up to about 225-230. As the car was running @ this temp. i checked to see if the fans were working and they were not. Which i believe at 220 Degrees they should turn on. The car didnt show signs of wanting to stall but like i said the Service Engine Soon light did come on and it seemed like it began to over heat from watching the degrees go up. Any ideas?
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #5 ·
Yea it reached 224 and i didnt see the fans working. And no, i didnt pull the codes this time but i had done it a few days ago when the light was on and it read....

po36 history- EGR Valve pintle position out of range
po31 history- Shorted map sensor
so44 history- lift or drive signal fault
ro15- passegnger intiator circuit resistance
so61-right front position sensor fault(had it for a while)
 

·
Super Moderator
2010 DTS
Joined
·
88,551 Posts
P036 could certainly cause a stall. Pull the EGR valve and clean the pintle. Not sure about P031, but it needs to be replaced anyway.
 

·
Registered
1996 Eldorado
Joined
·
2,814 Posts
The first thing you need to do is pull the boots away from the battery cable lugs & look for acid corrosion & make sure they are tight.
 
1 - 7 of 7 Posts
Top