Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I need some help. My sedan DeVille A/C was working fine then the A/C refridgerant light came on ( low level light). The A/C pump shut down like it was supposed too. I had it recharged (about 16 oz.) but the technician can't get the dash light indicator off nor the A/C pump to start.

How do I get the thing going. I followed the manuals sequence, but still nothing. Im not taking it to the dealership since they will charge me $100 just to look at it. I don't think the pump is out or broken since it was working well prior to the fluid drop.

What can I do?

Carl
 

·
Registered
Joined
·
40 Posts
I don't know what technician you took it to, but as far as I know, you can't recharge the system with refridgerant without the A/C compressor running. Disconnect a battery cable, hook up recharge lines and start car with A/C on then you can recharge with more refridgerant.
 

·
Registered
13 Challenger RT, 11 CTS Coupe Premium, 94 Eldorado (RIP)
Joined
·
1,306 Posts
Nothing is disconnected. That is the way the sensor controls things on these caddies. Like Bubba said, in order to properly add refrigerant, the compressor must be running. In order to get it running after the sensor tripped from low pressure, you must reset the codes by either going into the OBD or by disconnecting the battery for a little bit. When you start the car back up, don't waste any time getting to the refill. There is some delay before the sensor will trip, but I don't know how long.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,242 Posts
After clearing the codes as mentioned above, have the can hooked up and ready to go. Have someone start the car and have the A/C on max cooling. It should draw in the refrigerant before it can trip the code and shut down again. Hold the can upside down so it fills as a liquid or it will take forever and it WILL disengage the comnpressor.
 
1 - 5 of 5 Posts
Top