Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
95 Fleetwood Brougham, 76 Coupe De Ville
Joined
·
48 Posts
Discussion Starter #1
Hey Folks,

I have a 1995 Fleetwood Brougham. It is the greatest car ever made, except for the heated seats. The driver's side heated seat stopped working shortly after I bought the car. You would turn the switch on and the led light would blink off if you went over a bump or nudged it in the slightest way. The unit would work intermittently, but not for long. Now the light doesn't come on at all. I looked at the connectors and they appear to be plugged in. when I flip the switch, I can hear a click come from a black box under the seat, but no heat. I have heard that the heating grids under the seatcover commonly stop working on these cars. Is there a way to tell whether it is the switch, the little black box under the seat, the grids or something else that is at fault. I would love to go through the winter nice and toasty.

Thanks,
Jed
 

·
Registered
'93 Fleetwood Brougham...Dad's
Joined
·
4,382 Posts
That seems almost identical to the issues I've had on my '93.

When we first got it, the driver's side heat worked perfectly, but you had to either wiggle or click the switch hard for the light to come on--sometimes it flickered too. But, the heat still worked, so I ignored it.

Then, about a year ago, I noticed that now the light never came on and the heat didn't seem to work at all. Similarly, on the passenger's side that still had a perfectly working light AND heating element, neither seem to work anymore.

Odd, but definately some kind of electrical malady, that we just haven't had the time to figure out...but I want my butt warmers back!
 
1 - 2 of 2 Posts
Top