Cadillac Owners Forum banner

1 - 18 of 18 Posts

·
Registered
1995 DeVille 4.9L (with skirts)
Joined
·
63 Posts
Discussion Starter #1
my cadi was sputtering and stalling I figured fuel pump so I changed it and the filter .....all went fine ...now it wants to die out if you try excellerate it boggs down and my fuel level indicator went crazy then fine ........so it drives normal until you hit the gas to opass some one or pull out quickly ....was told to check the fule preasur regulator ..... oh and I had car running and pulled the fuel pump relay and car kept running ...then pulled the pump power fuse and car died ....any advise......I am thinking about droopping tank and cleaning it real good any advise for that task...as well...
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,286 Posts
my cadi was sputtering and stalling I figured fuel pump so I changed it and the filter .....all went fine ...now it wants to die out if you try excellerate it boggs down and my fuel level indicator went crazy then fine ........so it drives normal until you hit the gas to opass some one or pull out quickly ....was told to check the fule preasur regulator ..... oh and I had car running and pulled the fuel pump relay and car kept running ...then pulled the pump power fuse and car died ....any advise......I am thinking about droopping tank and cleaning it real good any advise for that task...as well...
-----------------------------
DIAGNOSIS is always a better solution -
rather than throwing parts at it -

first - check for codes -

check fuel pressure at the fuel rail -
should be 40 to 45 psi -

your problem sounds more like a bad ground -
or possibly a failing ignition module - or pick-up coil -
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,792 Posts
now it wants to die out if you try excellerate it boggs down.
so it drives normal until you hit the gas to opass some one or pull out quickly.
That sounds exactly like the symptoms my '92 had when the fuel pump started to fail. Put a fuel pressure gauge (with a long hose) on it and tape the gauge to your windshield. Take it out and drive it and give it some WOT. If the fuel pressure falls off at WOT, the pump is NFG.
 

·
Registered
1995 DeVille 4.9L (with skirts)
Joined
·
63 Posts
Discussion Starter #4
oh my bad it thru these codes ...P041..P075..P099..and T007.... I cleared and this one came back... P041... and I just installed a new one .....pump that is ... was iunder impression all pumps were about the same .....two year warranty 130 plus tax.......going to check the fuel preasure in like twenty mins ...and a new FPR is like forty bucks .....regulator
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Codes are meaningless without definitions. There's a link to code definitions within the sticky on how to pull DTCs.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,286 Posts
oh my bad it thru these codes ...P041..P075..P099..and T007.... I cleared and this one came back... P041... and I just installed a new one .....pump that is ... was iunder impression all pumps were about the same .....two year warranty 130 plus tax.......going to check the fuel preasure in like twenty mins ...and a new FPR is like forty bucks .....regulator
===============================
always include the code definitions along with the codes -
most of us have forgotten any OBD1 we used to know -
 

·
Registered
1995 DeVille 4.9L (with skirts)
Joined
·
63 Posts
Discussion Starter #8
P041 (E041) ................... No Cam Reference Signal from Ignition Control Module this is the code that keep showing up... ok I replaced the egr valve and the pule pressure regulator .. . . .and let me say the cadi engineers got cussed out the put a torx head screw up side down and used thread locker ... dicks lol... any way took it for a drive did the same thing but less ....so the pedal gets pushed down and the care surges or gasps for air or fuel but everything shuts off....got back and was asking a mechanic a question and I knocked on the distributor and the car shut off.... after a short surge so I took out the coil cause that's the most top part of the distributor and went and got a new one I hope this solves the problem... any one have any other ideas ... I will report back in the morning after I take it for a test drive.....
\
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,792 Posts
P041 (E041) ................... No Cam Reference Signal from Ignition Control Module this is the code that keep showing up.
I think that say's it all.

.. ok I replaced the egr valve and the pule pressure regulator .
:hmm: Why would you replace the EGR valve & pressure regulator when the codes said "No Cam Reference Signal from Ignition Control Module"?
 

·
Registered
1994 SLS x 2 ---- 1993 Eldorado Sport ----- 1994 Deville 4.9
Joined
·
1,540 Posts
Ranger: Why would you replace the EGR valve & pressure regulator when the codes said "No Cam Reference Signal from Ignition Control Module"?
> Really. As all that stuff on the 4.9 in in the distributor.

I knocked on the distributor and the car shut off.... after a short surge so I took out the coil cause that's the most top part of the distributor and went and got a new one I hope this solves the problem... any one have any other ideas ...
> I would replace the entire distributor as a unit.
The 94 vintage distributor I took apart (needed a coil - mostly) was cooked inside.

----------
 

·
Registered
1995 DeVille 4.9L (with skirts)
Joined
·
63 Posts
Discussion Starter #11
OH SHIT lol I tapped on distributor after all that .....lol I was totally missing the code thing .......ok thanks ......I just replaced all that stuff a bout a year ago will try that...thanks

----------

i feel stupid lol
 

·
Registered
1994 SLS x 2 ---- 1993 Eldorado Sport ----- 1994 Deville 4.9
Joined
·
1,540 Posts
While you are digging around in there.
Pull and check a few spark plugs gap.
When my distributor (coil) died, I checked the plugs and found .80 gap.
:bigroll: No wonder the coil died.
 

·
Registered
1995 DeVille 4.9L (with skirts)
Joined
·
63 Posts
Discussion Starter #13
ok all I totally changed the distributor and it runs fine I think that the timing was set to forward in advance....so ineed to retard it a bit I think the guy helping me set it to 12 instead of 10 btdc.... any way will let all know how it went shortly...next is front struts ... ordered them from autozone will be here Tuesday yayo
 

·
Registered
1991 Cadillac Sedan deVille
Joined
·
591 Posts
Glad to hear you fixed your problem.

If you set your base timing to 12 degrees BTDC you'll have to always run 93 octane, as it'll ping with 91 (trust me, I've tried that). Set it to 10* if you still want to run it on the factory set premium (91 octane), or better - set it to 6* and run regular fuel. I have been running mine on regular (base timing at 6* BTDC) for almost two years with no noticeable diminution in engine power and fuel mileage.
 

·
Registered
1995 DeVille 4.9L (with skirts)
Joined
·
63 Posts
Discussion Starter #15
which notch is that the third ont and I jump the conection under the dash and put it in timing mode than set to ten ,,,turnrd off car took out juper and then urned car back on and the timing watotally jumped a head paasst twenty...its ideling a little slow now after I set it at zero...because of the big jump ......has a like oh you pushed the gas go to it but it will move quick as shit....?
 

·
Registered
1991 Cadillac Sedan deVille
Joined
·
591 Posts
The timing notches are as follows:
20*<
18*
16*<
14*
12*<
10*
8*<
6*
4*<
2*
0*<
So, to set it to 10* BTDC, jump the A&B pins on the ALDL and then rotate the distributor (while observing with the timing light) to align the crankshaft pulley shaft notch between the 3rd and 4th notches. If that's the way you set the timing, it's correct.
 
1 - 18 of 18 Posts
Top