Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Cadillac 1994 STS
Joined
·
12 Posts
Discussion Starter #1 (Edited)
After replacing ALL the sensors in the trans and putting in a new engine and trans, our Seville will not start out in 3 or Overdrive.... however put it in 1st or 2nd and begin driving then switch up at any time and it shifts w/o any problems. Local Caddy repairman was useless.... (bring it in and we can charge you to estimate it...)
Is there something in the computer that needs to be reset to allow for the shifting to be normal?
We're at wits end with this one.
Thank you!
 

·
Registered
94 ETC,97 STS
Joined
·
3,531 Posts
Do you mean putting the shifter in 3 or O and it won't move?

Does it creep or move at all or does it act like it's in neutral?
 

·
Registered
Cadillac 1994 STS
Joined
·
12 Posts
Discussion Starter #3
It acts as though it's in neutral and the engine only revs.... no creeping or crawling.
When decelerating, unless you almost stop.... you don't need to shift down.... it acts fine.
 

·
Registered
94 ETC,97 STS
Joined
·
3,531 Posts
The trans is supposed to default to 2nd if the solenoids go bad.

Have you checked the shift lever at the trans?
 

·
Registered
Cadillac 1994 STS
Joined
·
12 Posts
Discussion Starter #5 (Edited)
More info:
Already replaced the input speed sensor, but code PO 56 still comes up. (Is it possible that we need to redo this sensor again)
Also replaced the shift solenoids in the bottom but not the flat (sensor?) beside it that has 3 or 4 wires going into it.
 

·
Registered
94 ETC,97 STS
Joined
·
3,531 Posts
Have you checked the adjustment of the shift lever yet?

If you slowly move the shifter in the car does the trans engage between detents?
 

·
Registered
94 ETC,97 STS
Joined
·
3,531 Posts
You start out saying it does not engage OK....

Does it engage normally or not?

If the engine is running and you slowly move the shift lever is it engaging in between detents? Does R engage in the right spot? How did you adjust the shift arm on the trans?

Does it engage between 3rd and O ? Does moving the lever make any difference.

Since you replaced the solenoids might one be bad? Or not plugged in properly? You should get a code if it doesn't sense the solenoid coil.
 
1 - 8 of 8 Posts
Top