Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
2000 STS
Joined
·
34 Posts
Discussion Starter #1
:confused: After 140,000 miles my SLS is deciding to really do some tricks. I remember reading the PROM fix for the P039 problem that plagues the Vin Y Northstar engine. I have searched the forum over and have not found the part number for the replacement prom and my dealer when I ask him looks at me as though I grew another head on my shoulders.:cookoo: Can anyone help with the part number???
I have just had the tranny fluid changed - and the codes stopped for about a week and now they have come back with a vengance.

This morning on the way to work I got a message on the dashboard "BATTERY NO CHARGE" On a cold morning this happens occassionally and I receive a P110 notice on the computer. But today my battery voltage dropped to 11 volts before it kicked in. For those of us that remember when generators were the thing - it acted like a stuck voltage regulator -- I am sure the kids here have no idea what I am talking about. Is the regulator built into the alternator? Any suggestions on what is causing this -- is it a tell tale sign that the alternator is getting ready to go on me?:bighead:

Thank you one and all for your help - this forum is a blessing for all of us!
Larry in New Jersey
 

·
Registered
Joined
·
2 Posts
same problem i had with my 94 sls when it got real cold last year my car did the same exaxct thing. Trust me ur alternator is goining bad its not ur battery.
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
P039 could be a number of different things. I have the diagnostics flow charts for code P039 on my computer. The P110 is something to do with the alternator though.
If you want them, you can e-mail me at:

Krashed989 @gmail.com

take out the space.
 
1 - 3 of 3 Posts
Top