Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
alright so since noone is lookin in my othere thread i thought maybe i would start another, anyway when i went to pick the car up the low beams wouldnt work so i had to drive home with the high beams on. i changed out the bulbs and checked the fuse under the hood, i guess im going to replace the fuse in the drivers compartment today and see if that works. anyone have any ideas on what could be the problem? i need to fix it by this weekend as im driving the car to a car meet on sat. any info would be great. thanks jeremy
 

·
Registered
'94 Fleetwood Brogham, '94 Fleetwood, 2010 SRX 4WD, F250
Joined
·
768 Posts
I'm thinking the dimmer switch may be bad. I only have a '94 FLTWD electrical diagram, but the switch circuit should be about the same. Check the dimmer switch terminal connecting the low-beam lights. On the '94, that's terminal "C" (tan wire, high beam wire is Lt Green). There is also (on the '94) a connector between the dimmer and the lights forward of the firewall in the engine comp. It is a two wire connector (low beam "A" side, and high beam, "B" side); again, Tan wire provides power to the low-beams from dimmer switch to the light connector.

The ground wires are not common to all four head lights, but they do converge to a central grounding point. Since the high beams are working I think the ground connection is good. Also, I wouldn't think you could have two separately bad grounds, one for each low beam.

Hope this helps. Good luck.
 

·
Registered
'94 Fleetwood Brogham, '94 Fleetwood, 2010 SRX 4WD, F250
Joined
·
768 Posts
Well.....duh ... :bonkers: I guess the electrical would be a close match, seeing how you have a '94 toooo.

Don't know what I was thinking when replying to your msg. Your login name had me think'n STS.
 
1 - 4 of 4 Posts
Top