Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
Hi everyone - Have a question about my '94 Eldo ETC. I have the analog cluster installed, and just had an engine swap done. Everything is supposedly hooked up however the speedometer is not functioning. The tach and other guages are working properly. The gas guage was not registering fuel (it would move slightly when power applied but nothing else) however it just started registering by itself about an hour or so later. We jacked up the car and verified that the speedo wire is plugged into the speed sensor. Any ideas of what I can do to get that speedo functioning? Also, I have a 94 Deville with the digital cluster - will it interchange with the 94 Eldo? Thinking about swapping it into the car I know works and verifying the speedo functionability. Also, will the Deville speed sensor swap to the Eldo? Thanks to all for your advice!

Ken
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
The dash wont interchange..... Analog/digital that is.....

Does the tranny shift weird sometimes??? If not, then SOMETHING isnt connected.... There are 2 speed sensors, one on the tranny, and another one inside the drivers side wheel well.... The first one is a PITA to get to, the second one is pretty easy.......

Best advice I can give you is check your OBD codes, and then we can go from there!
 

·
Registered
Joined
·
111 Posts
Discussion Starter #4
elwesso said:
The dash wont interchange..... Analog/digital that is.....

Does the tranny shift weird sometimes??? If not, then SOMETHING isnt connected.... There are 2 speed sensors, one on the tranny, and another one inside the drivers side wheel well.... The first one is a PITA to get to, the second one is pretty easy.......

Best advice I can give you is check your OBD codes, and then we can go from there!
Wes, Thanks for the help.

The transmission shifts hard and firm. I wished my Concours shifted as nicely as this car does.

I got the codes which may shed some light on this:

PO24 Current - Vehicle Speed Sensor Signal to TCC
PO71 History - Intermittent MAP Signal
TO31 History - RR Wheel Speed Sensor Fault
TO33 History - RR Speed Sensor Continuity Fault
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Alright.... Someone wil have to correct if wrong, but I think its the sensor thats on the drivers side wheel well.... I cant be sure, though.....

I wouldnt take my advice until its confirmed.....

Clear your codes and then see what comes up.....
 
1 - 5 of 5 Posts
Top