Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
1994 Ccadillac Deville Concours
Joined
·
21 Posts
Discussion Starter #1
hello all,

i have a 94 Concours with the north star on the way home i was at a light and on take off the dash said 0 MPH and sounded like it didnt shift , then its like it kicked in and said 20 MPH (or so) and ran fine.. did it a few more times

what makes it read 0 MPH and still drive ??

thanks for the help
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,030 Posts
You need to use the sticky thread at the top of this main page - "How to pull codes" - and get any stored Diagnostic Trouble Codes from your car's built-in code reader/scanner. Read the entire thread and practice. Write any codes down and return to the sticky and open the proper link for your year car - you're looking for the link with "obd1" in the URL. Use the Master Index box to decipher any codes found.

You may have a bad or failing VSS - Vehicle Speed Sensor - check the connector for the unit - it's on top of the passenger side transmission output shaft case.
 

·
Registered
1994 Ccadillac Deville Concours
Joined
·
21 Posts
Discussion Starter #3
did just that the one current code is

S038 ................... Electronic Level Control Exhaust Valve Short to Ground/Open


history is

p024
s021
s037
s044
s055
s073
 

·
Registered
1994 Ccadillac Deville Concours
Joined
·
21 Posts
Discussion Starter #4
FIXED

new vss run fine now lets hope thats all it was
 
1 - 4 of 4 Posts
Top