Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac
Joined
·
82 Posts
Discussion Starter #1
The car ran fine on the way to work. When leaving all it did was turn over. I'm not getting any spark. The module tested good and as far as I can tell with my meter the coil is good. I'm short on cash so I bought a used distributor and used it for parts. I still have the same result. It turns over fast and strong but will not start. Any ideas would be appreciated. I'm gonna run the other module to be tested to make sure it is good.

jeremy
 

·
Registered
69 Thunderbird | 90 Seville | 03 Corolla | 89 Marquis(scrapped) | 72 Torino(scrapped)
Joined
·
2,026 Posts
Are you sure theres no spark? If there is it could be a fuel issue...

Check the pickup coil inside the distributor with your ohm meter. Resistance should be between 500 and 1500 ohms. Make sure the distributor is getting power with the key on. Any trouble codes?
 

·
Registered
Cadillac
Joined
·
82 Posts
Discussion Starter #3
Yup no spark. I decided to take the module to another auto parts store and it tested out bad. I knew I should not have trusted Orielly's. They never get anything right. Hopefully this will get her going. Too bad I work this weekend.

jeremy
 

·
Registered
69 Thunderbird | 90 Seville | 03 Corolla | 89 Marquis(scrapped) | 72 Torino(scrapped)
Joined
·
2,026 Posts
Well the module is only $20 so you might as well swap it out for peace of mind if nothing else.
 

·
Registered
69 Thunderbird | 90 Seville | 03 Corolla | 89 Marquis(scrapped) | 72 Torino(scrapped)
Joined
·
2,026 Posts
I'm getting 21.99 at Autozone in 32907 area code for a 94 Deville. Where do you live? Any GM 7-pin module will work. Try Rockauto.com also.
 
1 - 6 of 6 Posts
Top