Cadillac Owners Forum banner

1 - 20 of 30 Posts

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #1
Over the past two weeks my car has been randomly stalling while driving. No codes, so my first thought is fueling issues. So i put a pressure gauge on it today, cycle key prime is only 30psi and with the car running at idle the needle on the gauge shakes between 35-38psi. could a clogged fuel filter cause this, or do you thing its a dieing fuel pump?

thanks!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
Those pressures are a little low. Could be a weak pump. I'd tape the gauge to the windshield and drive it til it dies keeping one eye on the gauge. If the pressure starts to fall before it dies, then the pump is the culprit.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #3
well i changed the fuel filter and checked the pressure. when the pump primes the needle goes to 50psi the falls really fast to 38. when the car is running the needle doesn't shake anymore but it held a 38.

today was a bad day, the car died about 4 times. the first time it just stalled. got it running again, drove 50 feet and the car stuttered and then stalled again. put the pressure gauge on it, got the car to start and i got 35psi running. this is on the side of the road mind you. so with the car running i decided to keep going. drove it another 15miles to my shop. about half way the car hiccuped and almost died a couple times. on the last turn to my shop the car stalled again. this time with no starting. just a couple fires and that was it. i tried starting it enough times that the anti-theft system told me i had to wait 3 mins lol. anyway finally the car starts again and i get to my shop. the pump still shows 35psi.

i ordered a fuel pump for tomorrow. was this a wise move?
any input you guys could give me tonight before i go ahead and install this thing would be great. im getting 0 codes.

thanks
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
I would drive it with the gauge taped to the windshield so you can see what happens to the fuel pressure. If it won't start, try spraying some Brakleen or such in the TB. If it runs on that, then it is definitely the fuel pump.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #5
the line isnt long enough to have the gauge in the window. im borrowing the gauge so i cant cut it. im not even sure how much i want to drive it because its getting worse. if i get it stuck away from my shop i really dont want to hve it towed. what else could cause this?

thanks so far!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
Yeah, mine was to short also. I got a brass barbed coupler from the hardware store and another length of fuel line and lengthened it so that it was useful if I ever needed it again. You can also replace the hose with an old R12 A/C gauge hose. Short of that, replace the pump and see if that helps. Kind of sounds like a failing pump anyway.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #7
so i changed the pump today and i still have low fuel pressure, 35psi running... no clue if the car still stalls because it is up in the air right now with the tank just sitting in place with a jack, but i can tell you i definately dont think its fixed. i think i have 2 problems now. what ever is causing the car to stall and what ever is causing the low pressure.

Would a failing regulator cause this?
Would a failing pulsalator cause this?
Would a failing crank sensor throw a code?

any ideas please, im about ready to set this car on fire and drive my honda...
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
I don't think a FPR would cause that, but it is easy enough to check.

What's a pulsalator?

A bad CKP sensor should set a code, but they have been known not to.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #9 (Edited)
do any gaskets have to be replaced to pull the manifold lid off?

a pulsalator is the device at the fuel pump that smooths out the fuel pulses coming from the pump. when they fail fuel bypasses through them and falls back into the tank, creating low fuel pressure.

is there anyway to test the cp sensors?

thanks again
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
Never had a '93 or '94 so I am not sure , but I don't think any gaskets need to be replaced.

I think you may be referring to the FPR (Fuel Pressure Regulator). Pull the vacuum hose at idle. If there is any fuel present at the nipple, then it needs to be replaced.

There probably is a way to test the CKP sensors, but I'm not sure how.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #12
car still stalls, fpr looks fine, i finally had the fressure gauge on it when it stalls and the fuel stays solid, so its something else. crank sensor?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
Boy, I don't know. CKP sensor is a possibility, but not a common problem on a '93.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #14
well i attempted to drive it to my shop today. it seems to start stalling after about 15-20min of driving. on the highway when the car starts to stall, if i hold my foot at about half throttle the car bucks really hard cutting in and out until it either makes it through it. today it didn't die just cutting in and out violently. oh ya and my drivers front wheel bearing is making noise, YAY!!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,118 Posts
When the fuel pump went on my '92, it ran fine when cold (first :10 - 15 min) even at WOT. after that if I went WOT it would fall flat on it's face, but would run just fine otherwise. I'm sure had I let it go it would have gotten worse. Maybe a bad ICM or coil.
 

·
Registered
1997 deville
Joined
·
16 Posts
you know i had the same problem on my 2000 dts, sometimes i would like pull up to a light and it would just die. but it would allways start back up. i took it in and they told me it was a crank sensor. ran fine after they fixed it! it was a 2000 dts with the northstar motor
 

·
Registered
88 Eldorado Biaritz
Joined
·
2 Posts
Do you have any more info. on your problem. I've got an identical situation on an 88 Eldorado and am hoping that you figure out what's wrong with yours so I don't start replacing parts. Any updates would be great.
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #18 (Edited)
currently is still does it, it takes a shorter amount of time now. if i keep it above 2000rpm all the time, when whatever cuts out, the motor is spinning enough to make it through it and keep running, sometimes it still dies. whens it is dying there is no black smoke that comes out the exhaust which would lead me to believe that its not ignition related only (an ignition cut typically will cause things to load up and run rich when the cyl fires again or just spew out raw fuel) but i dont know if thats possible on with N* ECU tho. it seems like everything cuts out at once, spark and fuel, so i'm assuming if the crank sensors are failing the ecu loses the sync and everything cuts out. right? this is my first coil pack car btw. i'm used to efi that uses the distributor for timing instead of the crank. I WISH IT WOULD THROW A CODE!!! i really liked this car up until now....
 

·
Registered
1993 Cadillac Eldorado Touring Coupe
Joined
·
40 Posts
Discussion Starter #20
this car is going to kill me. so far i can find no-one in canada to get me some crank sensors...

is it possible to switch the sensors around and see if it stays running? isnt one just for reference? and say if it does stay running then i know the other sensor is bad?

any ideas please!
 
1 - 20 of 30 Posts
Top